aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php
diff options
context:
space:
mode:
authorClaude Bing <me@claudebing.com>2020-05-06 19:53:41 -0400
committerArmin Kuster <akuster808@gmail.com>2020-05-17 14:32:08 -0700
commitecce4fe695cc1ac6a7688e9579551683fbab0ca5 (patch)
treeb86f7bb22c0f5726f841bd8711fc4572d02ea7ee /meta-oe/recipes-devtools/php
parent775ad5a08ec9fa80c6e731d69ca45c22c6664d9e (diff)
downloadmeta-openembedded-ecce4fe695cc1ac6a7688e9579551683fbab0ca5.tar.gz
php: fix PACKAGECONFIG for soap
PHP 7.4 enables libxml by default and removed it as a configurable option. Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 7aeef522ff3522ccf76a6750846e235e7c80427a) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/php')
-rw-r--r--meta-oe/recipes-devtools/php/php_7.4.4.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/php/php_7.4.4.bb b/meta-oe/recipes-devtools/php/php_7.4.4.bb
index c1784a78d9..a76dcaad37 100644
--- a/meta-oe/recipes-devtools/php/php_7.4.4.bb
+++ b/meta-oe/recipes-devtools/php/php_7.4.4.bb
@@ -93,7 +93,7 @@ PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_LIBDIR}/.. \
,--without-sqlite3 --without-pdo-sqlite \
,sqlite3"
PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_TARGET}${exec_prefix},--without-pgsql,postgresql"
-PACKAGECONFIG[soap] = "--enable-libxml --enable-soap, --disable-soap, libxml2"
+PACKAGECONFIG[soap] = "--enable-soap, --disable-soap, libxml2"
PACKAGECONFIG[apache2] = "--with-apxs2=${STAGING_BINDIR_CROSS}/apxs,,apache2-native apache2"
PACKAGECONFIG[pam] = ",,libpam"
PACKAGECONFIG[imap] = "--with-imap=${STAGING_DIR_HOST} \