aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-lxml_3.0.2.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-02-08 15:33:13 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-16 05:52:17 +0100
commit45809914310d4d4eda5982e1680f28c334f90769 (patch)
treefd4e3f670608964944562dcb8b981826e2e76ea1 /meta-oe/recipes-devtools/python/python-lxml_3.0.2.bb
parent9d19f0ee34f25c824fee9c51728a86a686d7b162 (diff)
downloadmeta-openembedded-45809914310d4d4eda5982e1680f28c334f90769.tar.gz
python-lxml: update to 3.0.2 and tweak
* Update to version 3.0.2 * Update LIC_FILES_CHKSUM - substance of the license did not change, but some copyright/origin notes for specific parts were added. * Add SUMMARY * Move packaging definitions to the end Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-lxml_3.0.2.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python-lxml_3.0.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-lxml_3.0.2.bb b/meta-oe/recipes-devtools/python/python-lxml_3.0.2.bb
new file mode 100644
index 0000000000..5ab7b4a793
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-lxml_3.0.2.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Python XML bindings for libxml2 and libxslt"
+DESCRIPTION = "Powerful and Pythonic XML processing library combining \
+libxml2/libxslt with the ElementTree API."
+HOMEPAGE = "http://codespeak.net/lxml"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=f9f1dc24f720c143c2240df41fe5073b"
+SRCNAME = "lxml"
+
+DEPENDS = "libxml2 libxslt"
+
+SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml"
+SRC_URI[lxml.md5sum] = "38b15b0dd5e9292cf98be800e84a3ce4"
+SRC_URI[lxml.sha256sum] = "cadba4cf0e235127795f76a6f7092cb035da23a6e9ec4c93f8af43a6784cd101"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+DISTUTILS_BUILD_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \
+"
+
+DISTUTILS_INSTALL_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN} += "libxml2 libxslt python-compression"
+RDEPENDS_${PN}_virtclass-native = "libxml2-native libxslt-native"
+