aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorPeter A. Bigot <bigotp@acm.org>2011-12-31 17:40:21 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-01-05 10:14:21 +0100
commit62332b8522f131d59136b4170dc8073638ec5641 (patch)
treec86790192c6d668cfbda3e8a7c876c5be55f962a /meta-oe/recipes-devtools/python
parentc65139cd012231db6c3994481d11fe118773afab (diff)
downloadmeta-openembedded-62332b8522f131d59136b4170dc8073638ec5641.tar.gz
python-pyusb: add recipe to support usb development in Python
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb b/meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb
new file mode 100644
index 0000000000..4048f4b9c2
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyusb_1.0.0a2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "PyUSB provides USB access on the Python language"
+HOMEPAGE = "http://pyusb.sourceforge.net/"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a53a9c39efcfb812e2464af14afab013"
+DEPENDS = "libusb1"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/pyusb/${SRCNAME}-${PV}.tar.gz \
+"
+SRC_URI[md5sum] = "9136b3dc019272c62a5b6d4eb624f89f"
+SRC_URI[sha256sum] = "dacbf7d568c0bb09a974d56da66d165351f1ba3c4d5169ab5b734266623e1736"
+
+SRCNAME = "pyusb"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils