aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-04-29 14:34:14 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-05-10 13:57:33 +0200
commit98d69cc39a04ddfcbce9a3cd736cfe1fc0dcf2dc (patch)
tree54309877e96f8d164f654d184bb1389174b8ec88 /meta-oe/recipes-devtools/python
parenta8242537b64a16fe7c1b808ace17353ee0b856f3 (diff)
downloadmeta-openembedded-98d69cc39a04ddfcbce9a3cd736cfe1fc0dcf2dc.tar.gz
python-argparse: add new recipe to provide argparse module for python and python-native older then 2.7
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-argparse_1.2.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-argparse_1.2.1.bb b/meta-oe/recipes-devtools/python/python-argparse_1.2.1.bb
new file mode 100644
index 0000000000..a026a255a9
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-argparse_1.2.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python command-line parsing library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=09d08bb5b7047e2688ea3faad6408aa8"
+SRCNAME = argparse
+
+SRC_URI = "http://argparse.googlecode.com/files/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "2fbef8cb61e506c706957ab6e135840c"
+SRC_URI[sha256sum] = "ddaf4b0a618335a32b6664d4ae038a1de8fbada3b25033f9021510ed2b3941a4"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+BBCLASSEXTEND = "native"