aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-02 12:55:29 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-02 13:00:03 +0100
commite57d05be92efb823d43188a08f40e3cceeb41175 (patch)
treebc6398e45a8fa68629e8789fe90d03cbb336b111 /meta-oe/recipes-devtools/python
parent02147ad225cced787bf3b1ab607fd38f8e132b47 (diff)
downloadmeta-openembedded-e57d05be92efb823d43188a08f40e3cceeb41175.tar.gz
python-simplejson: import from OE classic and update to 2.2.1
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb b/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb
new file mode 100644
index 0000000000..8e42dc7f42
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-simplejson_2.2.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8a9f8dcfcd28c34daa443e5b1d29813b"
+
+SRCNAME = "simplejson"
+
+SRC_URI = "http://cheeseshop.python.org/packages/source/s/simplejson/${SRCNAME}-${PV}.tar.gz"
+SRC_URI[md5sum] = "070c6467462bd63306f1756b01df6d70"
+SRC_URI[sha256sum] = "e85c5ae24dd9827113893c1dd2c799528195057388096f0fc45ad4b32b378c26"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} = "\
+ python-core \
+ python-re \
+ python-io \
+ python-netserver \
+ python-numbers \
+"
+
+