aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorLukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de>2014-02-12 20:46:07 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-02-21 17:06:59 +0100
commitdfa33ddb23ba4a6cba2884091e6fa6808c051f37 (patch)
treeddaf07fe65c839d44ae96d7059a3136de4599d14 /meta-oe/recipes-devtools/python
parent1f89f0a54e85e540e50bb00305b4163e13b1b4dc (diff)
downloadmeta-openembedded-dfa33ddb23ba4a6cba2884091e6fa6808c051f37.tar.gz
python-m2crypto: special setting for x86-64 architecture
After python-m2crypto was reported as failed task in bitbake world on 2014-02-08 by Martin Jansa, I investigated python-m2crypto with MACHINE = "qemux86-64" setting. When compiling python-m2crypto for qemux86-64, the setup.py aborts in the swig call with: | swig -python -I[...]/tmp-eglibc/sysroots/qemux86-64/usr/include/python2.7 -I[...]/tmp-eglibc/sysroots/qemux86-64/usr/include -includeall -o SWIG/_m2crypto_wrap.c SWIG/_m2crypto.i | [...]/tmp-eglibc/sysroots/qemux86-64/usr/include/openssl/opensslconf.h:41: Error: Unable to find 'openssl/opensslconf-32.h' | error: command 'swig' failed with exit status 1 | ERROR: python setup.py build_ext execution failed. | WARNING: exit code 1 from a shell command. To compile for x86-64 architecture, opensslconf.h shall include opensslconf-64.h, not opensslconf-32.h. Properly including opensslconf-64.h can be configured through the bits/wordsize.h header and setting the __x86_64__ directive in the swig call. To set the directive, the SWIG_FEATURES variable for x86-64 is set and exported in the recipe. Compiling python-m2crypto for qemumips still fails and needs further adjustments, but is not addressed here. This patch follows Khem Raj's suggestion on the openembedded-devel mailing list after submission of the first commit to this issue. Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb b/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb
index 9babc04e30..c88b9355d7 100644
--- a/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb
+++ b/meta-oe/recipes-devtools/python/python-m2crypto_0.21.1.bb
@@ -16,4 +16,8 @@ S = "${WORKDIR}/M2Crypto-${PV}"
inherit setuptools
+SWIG_FEATURES_x86-64 = "-D__x86_64__"
+SWIG_FEATURES ?= ""
+export SWIG_FEATURES
+
BBCLASSEXTEND = "native"