aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-27 09:07:11 -1000
committerArmin Kuster <akuster808@gmail.com>2021-01-28 17:00:42 -0800
commit52967af42380080a89f70c4c91bbaeca2a37b9f9 (patch)
tree879e75a974ad797e60d52ca0ede40335c03b06c6 /meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
parent112b03d7a40c6bfb6c70d4cb555e9ece48f198d7 (diff)
downloadmeta-openembedded-52967af42380080a89f70c4c91bbaeca2a37b9f9.tar.gz
sip3: Upgrade 4.19.19 -> 4.19.23
Upgrade to release 4.19.23: - Added some missing quotes to configure.py - Fixed a race condition when calling the PyQt5-specific meta-call helper. - Fixed the wrapping of methods that return a Py_Ssize_t. - The code generator now distinguishes between the copy/assignment helper and the array helper when determining which helpers can be generated. - Fixed the code generation when making a copy of C++ object on the stack to the heap when the class has no suitable ctor. - Check there is a public copy ctor when we can't using an assigment operator as a workaround. - Preserve any current exception in the implementation of the wrapper dealloc functions. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 358b3982583c93fdc0a4cebdab31f923d77b7f8b) Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/sip/sip3_4.19.23.bb')
-rw-r--r--meta-oe/recipes-devtools/sip/sip3_4.19.23.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb b/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
new file mode 100644
index 0000000000..320755b844
--- /dev/null
+++ b/meta-oe/recipes-devtools/sip/sip3_4.19.23.bb
@@ -0,0 +1,47 @@
+SUMMARY = "SIP is a C++/Python Wrapper Generator"
+HOMEPAGE = "https://riverbankcomputing.com/software/sip/"
+SECTION = "devel"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE-GPL2;md5=e91355d8a6f8bd8f7c699d62863c7303"
+
+SRC_URI = "https://www.riverbankcomputing.com/static/Downloads/sip/${PV}/sip-${PV}.tar.gz \
+"
+SRC_URI[md5sum] = "70adc0c9734e2d9dcd241d3f931dfc74"
+SRC_URI[sha256sum] = "22ca9bcec5388114e40d4aafd7ccd0c4fe072297b628d0c5cdfa2f010c0bc7e7"
+
+inherit python3-dir python3native
+
+S = "${WORKDIR}/sip-${PV}"
+
+DEPENDS = "python3"
+
+PACKAGES += "python3-sip3"
+
+BBCLASSEXTEND = "native"
+
+do_configure_prepend_class-target() {
+ echo "py_platform = linux" > sip.cfg
+ echo "py_inc_dir = %(sysroot)/${includedir}/python%(py_major).%(py_minor)${PYTHON_ABI}" >> sip.cfg
+ echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg
+ echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg
+ echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg
+ echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg
+ ${PYTHON} configure.py --configuration sip.cfg --sip-module PyQt5.sip --sysroot ${STAGING_DIR_HOST} CC="${CC}" CXX="${CXX}" LINK="${CXX}" STRIP="" LINK_SHLIB="${CXX}" CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LFLAGS="${LDFLAGS}"
+}
+
+do_configure_prepend_class-native() {
+ echo "py_platform = linux" > sip.cfg
+ echo "py_inc_dir = ${includedir}/python%(py_major).%(py_minor)${PYTHON_ABI}" >> sip.cfg
+ echo "sip_bin_dir = ${D}/${bindir}" >> sip.cfg
+ echo "sip_inc_dir = ${D}/${includedir}" >> sip.cfg
+ echo "sip_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> sip.cfg
+ echo "sip_sip_dir = ${D}/${datadir}/sip" >> sip.cfg
+ ${PYTHON} configure.py --configuration sip.cfg --sip-module PyQt5.sip --sysroot=${STAGING_DIR_NATIVE}
+}
+
+do_install() {
+ oe_runmake install
+}
+
+FILES_python3-sip3 = "${libdir}/${PYTHON_DIR}/site-packages/"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"