aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2020-10-08 20:15:46 -0700
committerKhem Raj <raj.khem@gmail.com>2020-10-09 04:33:59 +0000
commit585f3e4fe05cc1ebe1e9da47712ae0d3d08d1a53 (patch)
tree84169f1f0c4e5e9c7885f01b693084a54b946104 /meta-oe/recipes-devtools
parentd9f87779d0ce056a9e09b6025d075d410909d46d (diff)
downloadmeta-openembedded-585f3e4fe05cc1ebe1e9da47712ae0d3d08d1a53.tar.gz
musl-nscd: add package
Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/musl/musl-nscd_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/musl/musl-nscd_git.bb b/meta-oe/recipes-devtools/musl/musl-nscd_git.bb
new file mode 100644
index 0000000000..374f944096
--- /dev/null
+++ b/meta-oe/recipes-devtools/musl/musl-nscd_git.bb
@@ -0,0 +1,37 @@
+# Copyright (C) 2020 Armin Kuster <akuster808@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules"
+HOMEPAGE = "https://github.com/pikhq/musl-nscd"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee"
+SECTION = "utils"
+
+PV = "1.0.2"
+
+CFLAGS += "-fcommon"
+
+SRCREV = "8f278675e1b6a3a02c8ee1b8ca000f80570dc5d6"
+SRC_URI = "git://github.com/pikhq/musl-nscd"
+
+UPSTREAM_CHECK_COMMITS = "1"
+
+inherit autotools-brokensep
+
+S = "${WORKDIR}/git"
+
+do_configure () {
+ # no debug set -s flag
+ sed -i -e 's/LDFLAGS_AUTO=-s/LDFLAGS_AUTO=/' ${S}/configure
+ ${S}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ make DESTDIR=${D} install
+}
+
+COMPATIBLE_HOST = ".*-musl.*"