aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2021-03-02 15:47:27 +0800
committerKhem Raj <raj.khem@gmail.com>2021-03-02 10:25:19 -0800
commite8deb92b7bfa2f2219c3f23a3fa52e506ef5d233 (patch)
treeda6bde525200133310cfbccc52fc9f1f21b57ce0 /meta-oe/recipes-devtools
parente8b86e3c103106e737ce47c672fb29a84e797a64 (diff)
downloadmeta-openembedded-e8deb92b7bfa2f2219c3f23a3fa52e506ef5d233.tar.gz
Fix do_package error when enable multilib.
ERROR: grpc-1.35.0-r0 do_package: QA Issue: grpc: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/pkgconfig /usr/lib/pkgconfig/grpc.pc /usr/lib/pkgconfig/grpc_unsecure.pc /usr/lib/pkgconfig/grpc++.pc /usr/lib/pkgconfig/gpr.pc /usr/lib/pkgconfig/grpc++_unsecure.pc Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. grpc: 7 installed and not shipped files. [installed-vs-shipped] ERROR: grpc-1.35.0-r0 do_package: Fatal QA errors found, failing task. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb b/meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb
index 5097b2b1b8..363e2b4680 100644
--- a/meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb
+++ b/meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb
@@ -35,6 +35,11 @@ EXTRA_OECMAKE = " \
-DgRPC_INSTALL_CMAKEDIR=${baselib}/cmake/${BPN} \
"
+do_configure_prepend() {
+ sed -i -e "s#lib/pkgconfig/#${baselib}/pkgconfig/#g" ${S}/CMakeLists.txt
+}
+
+
do_configure_prepend_mipsarch() {
sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt
}