aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMaciej Borzecki <maciej.borzecki@open-rnd.pl>2016-02-11 11:12:50 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:46 +0100
commit4047e5ca84c9b61fed0512b804aded0288679cf1 (patch)
tree566fb2ee5f6931948d29cf9815000da52a1f58c8 /meta-oe/recipes-devtools
parent21a983bc3358ded6cf514c704bad18d36b453b35 (diff)
downloadmeta-openembedded-4047e5ca84c9b61fed0512b804aded0288679cf1.tar.gz
lua: use PV for generating Version in lua.pc
Lua was updated to 5.3.2, however lua.pc still has 5.2.2 listed as Version in pkg-config metadata file. Instead of bumping the Version field in lua.pc make sure that we are future proof and update the field automatically with value of ${PV}. Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/lua/lua/lua.pc.in (renamed from meta-oe/recipes-devtools/lua/lua/lua.pc)2
-rw-r--r--meta-oe/recipes-devtools/lua/lua_5.3.2.bb4
2 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/lua/lua/lua.pc b/meta-oe/recipes-devtools/lua/lua/lua.pc.in
index e6f8b6f096..fe22016037 100644
--- a/meta-oe/recipes-devtools/lua/lua/lua.pc
+++ b/meta-oe/recipes-devtools/lua/lua/lua.pc.in
@@ -4,7 +4,7 @@ includedir=${prefix}/include
Name: Lua
Description: Lua language engine
-Version: 5.2.2
+Version: @VERSION@
Requires:
Libs: -L${libdir} -llua
Libs.private: -lm
diff --git a/meta-oe/recipes-devtools/lua/lua_5.3.2.bb b/meta-oe/recipes-devtools/lua/lua_5.3.2.bb
index 0cc882df2e..f97ed509f4 100644
--- a/meta-oe/recipes-devtools/lua/lua_5.3.2.bb
+++ b/meta-oe/recipes-devtools/lua/lua_5.3.2.bb
@@ -8,7 +8,7 @@ PR = "r0"
DEPENDS = "readline"
SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz;name=tarballsrc \
- file://lua.pc \
+ file://lua.pc.in \
"
SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', \
'http://www.lua.org/tests/lua-${PV}-tests.tar.gz;name=tarballtest \
@@ -47,6 +47,8 @@ do_install () {
'INSTALL_CMOD=${D}${libdir}/lua/5.3' \
install
install -d ${D}${libdir}/pkgconfig
+
+ sed -e s/@VERSION@/${PV}/ ${WORKDIR}/lua.pc.in > ${WORKDIR}/lua.pc
install -m 0644 ${WORKDIR}/lua.pc ${D}${libdir}/pkgconfig/
rmdir ${D}${datadir}/lua/5.3
rmdir ${D}${datadir}/lua