aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-24 14:57:01 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:26 +0200
commitb4d7caaff9ee7e3ba2f5756b3d2ea2de498d4c2f (patch)
treea6c368b68b1a6181cca37fda37bf5444e20e4512 /meta-oe/recipes-devtools
parentf0de8ed2c3301b8629d87a4e3357d580d4db154a (diff)
downloadmeta-openembedded-b4d7caaff9ee7e3ba2f5756b3d2ea2de498d4c2f.tar.gz
gnome-doc-utils-stub: add a recipe
Real gnome-doc-utils can no longer be build (because it requires both python 2 and libxml2, which can only be build for one version of Python), so a stub recipe which provides just m4 macros is provided, and usage of gnome-doc-utils is disabled where needed. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/geany/geany_1.27.bb4
-rw-r--r--meta-oe/recipes-devtools/glade/glade3_3.8.5.bb6
2 files changed, 4 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/geany/geany_1.27.bb b/meta-oe/recipes-devtools/geany/geany_1.27.bb
index 686222ac83..15b21da14e 100644
--- a/meta-oe/recipes-devtools/geany/geany_1.27.bb
+++ b/meta-oe/recipes-devtools/geany/geany_1.27.bb
@@ -2,7 +2,7 @@ SUMMARY = "A fast and lightweight IDE"
HOMEPAGE = "http://www.geany.org/"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=bd7b2c994af21d318bd2cd3b3f80c2d5"
-DEPENDS = "gtk+ python-docutils-native"
+DEPENDS = "gtk+ python3-docutils-native"
inherit autotools pkgconfig perlnative pythonnative
@@ -14,3 +14,5 @@ SRC_URI[md5sum] = "7c23f835f45def89d10884c1343fa29e"
SRC_URI[sha256sum] = "846ff699a5944c5c3c068ae0199d4c13946a668bfc6d03f8c79765667c20cadf"
FILES_${PN} += "${datadir}/icons"
+
+EXTRA_OECONF = "--disable-html-docs"
diff --git a/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb b/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb
index 4e7ef9b5ca..dcc0cbe735 100644
--- a/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb
+++ b/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb
@@ -4,7 +4,7 @@ LICENSE = "GPLv2 & LGPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=aabe87591cb8ae0f3c68be6977bb5522 \
file://COPYING.GPL;md5=9ac2e7cff1ddaf48b6eab6028f23ef88 \
file://COPYING.LGPL;md5=252890d9eee26aab7b432e8b8a616475"
-DEPENDS = "gtk+ gnome-doc-utils-native gnome-common libxml2"
+DEPENDS = "gtk+ gnome-doc-utils gnome-common libxml2"
inherit autotools pkgconfig pythonnative
@@ -18,10 +18,6 @@ EXTRA_OECONF += "--disable-scrollkeeper"
PACKAGECONFIG ??= ""
PACKAGECONFIG[gnome] = "--enable-gnome,--disable-gnome,libbonoboui libgnomeui"
-do_configure_prepend() {
- sed -i '/^if HAVE_GNOME_DOC_UTILS/,/^endif/d' ${S}/Makefile.am
-}
-
FILES_${PN} += "${datadir}/icons"
FILES_${PN}-dbg += "${libdir}/glade3/modules/.debug"
FILES_${PN}-dev += "${libdir}/glade3/modules/*.la"