aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-05-16 13:23:18 +0200
committerArmin Kuster <akuster808@gmail.com>2017-07-17 11:17:47 -0700
commitc7d2ad2e3ec3056c14d2a25bc2a5693f70ae1196 (patch)
tree98ac172119b8ed221a1d06aa11c69c84a7e5b2c1 /meta-oe/recipes-devtools
parentf0eb8fb1fa6668d8b2afd460eb0352e0ca603a07 (diff)
downloadmeta-openembedded-c7d2ad2e3ec3056c14d2a25bc2a5693f70ae1196.tar.gz
xerces-c: fix a wrong PACKAGECONFIG option
In xerces-c's configure, these options is being referred as follows: ...... curl_flags="-I$with_curl/include" curl_libs="-L$with_curl/lib -lcurl" icu_flags="-I$with_icu/include" icu_libs="-L$with_icu/lib -licuuc -licudata" ...... so they shouldn't be set to ${STAGING_DIR}, use ${STAGING_DIR_TARGET}${prefix} instead. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb b/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb
index b848b0693e..64ac74723a 100644
--- a/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb
+++ b/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb
@@ -16,8 +16,8 @@ SRC_URI[sha256sum] = "9408f12c1628ecf80730bedbe8b2caad810edd01bb4c66f77b60c873e8
inherit autotools
PACKAGECONFIG ??= "curl icu"
-PACKAGECONFIG[curl] = "--with-curl=${STAGING_DIR},--with-curl=no,curl"
-PACKAGECONFIG[icu] = "--with-icu=${STAGING_DIR},--with-icu=no,icu"
+PACKAGECONFIG[curl] = "--with-curl=${STAGING_DIR_TARGET}${prefix},--with-curl=no,curl"
+PACKAGECONFIG[icu] = "--with-icu=${STAGING_DIR_TARGET}${prefix},--with-icu=no,icu"
do_install_prepend () {
sed -i -e 's:-L${STAGING_DIR}/lib:-L\$\{libdir\}:g' ${B}/xerces-c.pc