aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/acpica/files/no-werror.patch
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2013-08-08 03:51:48 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-08-16 12:58:29 +0200
commitaf7ffe8bcd88270c0aebb212ee347061b21324d9 (patch)
treef009c20e005ee48a3e59819dee5ae24518fa4bb0 /meta-oe/recipes-extended/acpica/files/no-werror.patch
parent650c5fa94eb9902f6ecc4b8baa4b84b01f94c671 (diff)
downloadmeta-openembedded-af7ffe8bcd88270c0aebb212ee347061b21324d9.tar.gz
sdk: add acpica recipe
Signed-off-by: Naresh Bhat <naresh.bhat@linaro.org> Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org> Signed-off-by: Matt Ranostay <mranostay@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/acpica/files/no-werror.patch')
-rw-r--r--meta-oe/recipes-extended/acpica/files/no-werror.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/acpica/files/no-werror.patch b/meta-oe/recipes-extended/acpica/files/no-werror.patch
new file mode 100644
index 0000000000..9f96552fd0
--- /dev/null
+++ b/meta-oe/recipes-extended/acpica/files/no-werror.patch
@@ -0,0 +1,36 @@
+Description: remove -Werror flag
+Forwarded: not-needed
+Author: Fathi Boudra <fathi.boudra@linaro.org>
+
+---
+ generate/unix/iasl/Makefile | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+--- a/generate/unix/iasl/Makefile
++++ b/generate/unix/iasl/Makefile
+@@ -279,19 +279,19 @@ $(OBJDIR)/prparser.y.h: $(OBJDIR)/prpars
+ # by the utilities above and they are not necessarily ANSI C, etc.
+ #
+ $(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/prparserparse.o : $(OBJDIR)/prparserparse.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?