aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/hwloc
diff options
context:
space:
mode:
authorQi.Chen@windriver.com <Qi.Chen@windriver.com>2017-06-29 10:23:38 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-01 09:59:27 +0200
commitee55f2a29a3e5f2d6566519e6d9c0c7be81163f6 (patch)
treec03a100b860bc8f747e092958e5cf6e22ccc3b1f /meta-oe/recipes-extended/hwloc
parent90524a33745eaf3b842489f48bd1b7a352a117c0 (diff)
downloadmeta-openembedded-ee55f2a29a3e5f2d6566519e6d9c0c7be81163f6.tar.gz
hwloc: add several PACKAGECONFIG items
Add PACKAGECONFIG items to allow for more flexiblity. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/hwloc')
-rw-r--r--meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb b/meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb
index e067f27996..5cf6e7eb94 100644
--- a/meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb
+++ b/meta-oe/recipes-extended/hwloc/hwloc_1.11.5.bb
@@ -13,10 +13,16 @@ SRC_URI[sha256sum] = "95d80286dfe658a3f79e2ac90698782bb36e5504f4bac1bba2394ba14d
inherit autotools
-DEPENDS += "cairo ncurses udev libxml2 zlib libpciaccess"
-DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
+DEPENDS += "ncurses udev zlib"
DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'libselinux', '', d)}"
+PACKAGECONFIG ?= "pci libxml2 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+
+PACKAGECONFIG[numactl] = "--enable-libnuma,--disable-libnuma,numactl,numactl"
+PACKAGECONFIG[libxml2] = "--enable-libxml2,--disable-libxml2,libxml2,libxml2"
+PACKAGECONFIG[x11] = "--with-x,--without-x,virtual/libx11 cairo,cairo"
+PACKAGECONFIG[pci] = "--enable-pci,--disable-pci,libpciaccess,libpciaccess"
+
# Split hwloc library into separate subpackage
PACKAGES_prepend = " lib${PN} "
FILES_lib${PN} += "${libdir}/lib${PN}.so*"