aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-06-06 19:28:38 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-20 12:27:59 +0200
commit0368f18b3ff032c57f5bfa93cf1ffa398cc5bcc0 (patch)
treef8a250ecaaec47df48a2fe2288ab0f12af930149 /meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
parent31613424db9b61fd765fe14f8a332564cbeefe5f (diff)
downloadmeta-openembedded-0368f18b3ff032c57f5bfa93cf1ffa398cc5bcc0.tar.gz
mozjs: initial add 17.0.0
later versions of polkit will need it Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
new file mode 100644
index 0000000000..311372f015
--- /dev/null
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -0,0 +1,35 @@
+SUMMARY = "SpiderMonkey is Mozilla's JavaScript engine written in C/C++"
+LICENSE = "MPL-2.0"
+LIC_FILES_CHKSUM = "file://../../LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
+
+SRC_URI = " \
+ http://ftp.mozilla.org/pub/mozilla.org/js/${PN}${PV}.tar.gz \
+ file://0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch \
+"
+SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202"
+SRC_URI[sha256sum] = "321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c172fba"
+
+S = "${WORKDIR}/${PN}${PV}/js/src"
+
+inherit autotools pkgconfig perlnative
+
+DEPENDS += "nspr"
+
+# nspr's package-config is ignored so set libs manually
+EXTRA_OECONF = " \
+ --target=${TARGET_SYS} \
+ --host=${BUILD_SYS} \
+ --build=${BUILD_SYS} \
+ --prefix=${prefix} \
+ --with-nspr-libs='-lplds4 -lplc4 -lnspr4' \
+ --enable-threadsafe \
+"
+
+# mozjs requires autoreconf 2.13
+do_configure() {
+ ./configure ${EXTRA_OECONF}
+}
+
+PACKAGES =+ "lib${PN}"
+FILES_lib${PN} += "${libdir}/lib*.so"
+FILES_${PN}-dev += "${bindir}/js17-config"