aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen.kooi@linaro.org>2015-03-03 20:47:55 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-06 07:34:07 +0100
commit2a3ffe806afc5d23fc5a8086dee74d32afb5e66b (patch)
tree06e0e96e8d445a164a9853df2ac5e7afeefb490c /meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
parent5fffea1646b7a3db5c4a35b9b5fcc0ddadb63496 (diff)
downloadmeta-openembedded-2a3ffe806afc5d23fc5a8086dee74d32afb5e66b.tar.gz
mozjs 17.0.0: fix aarch64 and 64k page builds, generic cleanups
* Mozjs17 has problems with 64k page sizes (powerpc64, aarch64 and probably others) and lacks support for aarch64. Patches were lifted from the fedora src rpm and rediffed. * Regenerate configure with autoconf-2.13 to make the fixes mentioned above take effect. * Provide proper config.guess and config.sub files * Explicitly disable static builds and regroup configure options. * Also clean out the patches/ dir present in the tarball to avoid conflicts with the OE patcher. Signed-off-by: Koen Kooi <koen.kooi@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb29
1 files changed, 26 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index 174f6fe0a8..91ee9a27a5 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -4,9 +4,15 @@ LIC_FILES_CHKSUM = "file://../../LICENSE;md5=815ca599c9df247a0c7f619bab123dad"
SRC_URI = " \
http://ftp.mozilla.org/pub/mozilla.org/js/${BPN}${PV}.tar.gz \
- file://0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch \
file://0001-mozjs17.0.0-fix-the-compile-bug-of-powerpc.patch \
-"
+ file://0001-js.pc.in-do-not-include-RequiredDefines.h-for-depend.patch \
+ file://0002-Move-JS_BYTES_PER_WORD-out-of-config.h.patch;patchdir=../../ \
+ file://0003-Add-AArch64-support.patch;patchdir=../../ \
+ file://0004-mozbug746112-no-decommit-on-large-pages.patch;patchdir=../../ \
+ file://0005-aarch64-64k-page.patch;patchdir=../../ \
+ file://0001-regenerate-configure.patch;patchdir=../../ \
+ "
+
SRC_URI[md5sum] = "20b6f8f1140ef6e47daa3b16965c9202"
SRC_URI[sha256sum] = "321e964fe9386785d3bf80870640f2fa1c683e32fe988eeb201b04471c172fba"
@@ -22,16 +28,33 @@ EXTRA_OECONF = " \
--host=${BUILD_SYS} \
--build=${BUILD_SYS} \
--prefix=${prefix} \
+ --libdir=${libdir} \
--with-nspr-libs='-lplds4 -lplc4 -lnspr4' \
--enable-threadsafe \
- --libdir=${libdir} \
+ --disable-static \
"
# mozjs requires autoreconf 2.13
do_configure() {
+ ( cd ${S}
+ gnu-configize --force
+ mv config.guess config.sub build/autoconf )
${S}/configure ${EXTRA_OECONF}
}
+# patch.bbclass will try to apply the patches already present and fail, so clean them out
+do_sourceclean() {
+ (
+ cd ${WORKDIR}/${PN}${PV}/patches
+ for i in $(cat series | awk '{print $1}') ; do
+ rm -f $i
+ done
+ rm -f series
+ )
+}
+
+addtask sourceclean before do_patch after do_unpack
+
PACKAGES =+ "lib${PN}"
FILES_lib${PN} += "${libdir}/lib*.so"
FILES_${PN}-dev += "${bindir}/js17-config"