aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/mozjs
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-09-16 14:57:46 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-23 15:39:45 +0200
commitd33f7dacfee53c9f8036584080465cd50ccce891 (patch)
tree2202f3cbc47edae7ee445fbf7b3acb0bf40f9564 /meta-oe/recipes-extended/mozjs
parente29f64293c7aa5adc1ce9c4a698e6af889f8bb4f (diff)
downloadmeta-openembedded-d33f7dacfee53c9f8036584080465cd50ccce891.tar.gz
mozjs: add PACKAGECONFIG for x11
Add PACKAGECONFIG for x11 and enable it when x11 is included in DISTRO_FEATURES, and specify the correct path for x-includes and x-libraries to avoid searching the host libraries. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/mozjs')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index 6621a703e3..bb71707492 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -39,6 +39,9 @@ EXTRA_OECONF_append_armv4 += " \
--disable-methodjit \
"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
+PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR},--without-x,virtual/libx11"
+
# mozjs requires autoreconf 2.13
do_configure() {
( cd ${S}