aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/sanlock/sanlock_3.6.0.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-09-09 10:42:47 -0400
committerKhem Raj <raj.khem@gmail.com>2018-09-09 22:09:42 -0700
commit2d5b455f09e68be1c3c5c0e06696e8d5ffc12b06 (patch)
treeed8399443948e58948acca3523f31665134dd2b4 /meta-oe/recipes-extended/sanlock/sanlock_3.6.0.bb
parent8705570331c3ac5af2e36bdb6f8db3c2bea1f5b5 (diff)
downloadmeta-openembedded-2d5b455f09e68be1c3c5c0e06696e8d5ffc12b06.tar.gz
sanlock: add version 3.6.0
A shared storage lock manager. - Fix compile failure with musl - Fix installed-vs-shipped QA issue - Fix ldflags QA issue Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/sanlock/sanlock_3.6.0.bb')
-rw-r--r--meta-oe/recipes-extended/sanlock/sanlock_3.6.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sanlock/sanlock_3.6.0.bb b/meta-oe/recipes-extended/sanlock/sanlock_3.6.0.bb
new file mode 100644
index 0000000000..c51bccce3b
--- /dev/null
+++ b/meta-oe/recipes-extended/sanlock/sanlock_3.6.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "A shared storage lock manager"
+DESCRIPTION = "sanlock is a lock manager built on shared storage. Hosts with access \
+to the storage can perform locking. An application running on the \
+hosts is given a small amount of space on the shared block device or \
+file, and uses sanlock for its own application-specific synchronization. \
+Internally, the sanlock daemon manages locks using two disk-based \
+lease algorithms: delta leases and paxos leases."
+HOMEPAGE = "https://pagure.io/sanlock"
+SECTION = "utils"
+
+LICENSE = "LGPLv2+ & GPLv2 & GPLv2+"
+LIC_FILES_CHKSUM = "file://README.license;md5=60487bf0bf429d6b5aa72b6d37a0eb22"
+
+SRC_URI = "git://pagure.io/sanlock.git;protocol=http \
+ file://0001-fix-compile-failure-with-libc-musl.patch \
+ "
+SRCREV = "90b2ffa77edd46bea007b7bb39bfd4d2db2ff7af"
+S = "${WORKDIR}/git"
+
+DEPENDS = "libaio util-linux"
+
+inherit distutils
+
+do_configure[noexec] = "1"
+
+do_compile_prepend () {
+ oe_runmake -C wdmd CMD_LDFLAGS="${LDFLAGS}" LIB_LDFLAGS="${LDFLAGS}"
+ oe_runmake -C src CMD_LDFLAGS="${LDFLAGS}" LIB_ENTIRE_LDFLAGS="${LDFLAGS}" LIB_CLIENT_LDFLAGS="${LDFLAGS}"
+ cd ${S}/python
+}
+
+do_install_prepend () {
+ oe_runmake -C wdmd DESTDIR=${D} LIBDIR=${libdir} install
+ oe_runmake -C src DESTDIR=${D} LIBDIR=${libdir} install
+ cd ${S}/python
+}