aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/uml-utilities
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-01-06 00:18:27 -0800
committerKhem Raj <raj.khem@gmail.com>2013-01-08 09:31:51 -0800
commit4202d1a6e6573ed54fd242d8d7bf267ab71ee0e6 (patch)
tree693f00b4ec0b42b2eadd9282d8b0442ee182f5b9 /meta-oe/recipes-extended/uml-utilities
parent0be3c83eaa0b159e026a4bac278162335a7dca8f (diff)
downloadmeta-openembedded-4202d1a6e6573ed54fd242d8d7bf267ab71ee0e6.tar.gz
uml-utilities: Forward port recipe from OE classic
Imported at SHA e12cf65f2fd58135039d73b9290ebee763161416 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/uml-utilities')
-rw-r--r--meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch16
-rw-r--r--meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/unstrip.patch84
-rw-r--r--meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb26
3 files changed, 126 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
new file mode 100644
index 0000000000..05cc5371f7
--- /dev/null
+++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tools/mconsole/Makefile~fix-ldflags 2003-02-08 05:10:08.000000000 +0100
++++ tools/mconsole/Makefile 2004-04-01 15:37:37.000000000 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS) -lreadline -lncurses
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS) -lreadline -lncurses
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/unstrip.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/unstrip.patch
new file mode 100644
index 0000000000..868001dbd5
--- /dev/null
+++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/unstrip.patch
@@ -0,0 +1,84 @@
+Dont strip during install let the packaging handle it
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: tools/jailtest/Makefile
+===================================================================
+--- tools.orig/jailtest/Makefile 2003-02-07 20:10:27.000000000 -0800
++++ tools/jailtest/Makefile 2012-09-05 12:13:56.061615854 -0700
+@@ -14,4 +14,4 @@
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+Index: tools/mconsole/Makefile
+===================================================================
+--- tools.orig/mconsole/Makefile 2012-09-05 12:05:09.869607043 -0700
++++ tools/mconsole/Makefile 2012-09-05 12:14:07.725607469 -0700
+@@ -14,4 +14,4 @@
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+Index: tools/moo/Makefile
+===================================================================
+--- tools.orig/moo/Makefile 2003-06-26 09:27:00.000000000 -0700
++++ tools/moo/Makefile 2012-09-05 12:14:20.981604580 -0700
+@@ -22,4 +22,4 @@
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+Index: tools/port-helper/Makefile
+===================================================================
+--- tools.orig/port-helper/Makefile 2003-02-07 20:05:31.000000000 -0800
++++ tools/port-helper/Makefile 2012-09-05 12:14:39.429609678 -0700
+@@ -14,4 +14,4 @@
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(LIB_DIR)
+- install -s $(BIN) $(DESTDIR)$(LIB_DIR)
++ install $(BIN) $(DESTDIR)$(LIB_DIR)
+Index: tools/tunctl/Makefile
+===================================================================
+--- tools.orig/tunctl/Makefile 2003-02-07 20:05:04.000000000 -0800
++++ tools/tunctl/Makefile 2012-09-05 12:14:49.985606470 -0700
+@@ -14,4 +14,4 @@
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+Index: tools/uml_net/Makefile
+===================================================================
+--- tools.orig/uml_net/Makefile 2003-02-07 20:04:55.000000000 -0800
++++ tools/uml_net/Makefile 2012-09-05 12:15:00.961607290 -0700
+@@ -21,4 +21,4 @@
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s -m 04755 $(BIN) $(DESTDIR)$(BIN_DIR)
++ install -m 04755 $(BIN) $(DESTDIR)$(BIN_DIR)
+Index: tools/uml_router/Makefile
+===================================================================
+--- tools.orig/uml_router/Makefile 2003-02-07 20:04:39.000000000 -0800
++++ tools/uml_router/Makefile 2012-09-05 12:15:10.649607571 -0700
+@@ -20,4 +20,4 @@
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
+Index: tools/watchdog/Makefile
+===================================================================
+--- tools.orig/watchdog/Makefile 2003-02-07 20:04:25.000000000 -0800
++++ tools/watchdog/Makefile 2012-09-05 12:15:35.561612203 -0700
+@@ -14,4 +14,4 @@
+
+ install : $(BIN)
+ install -d $(DESTDIR)$(BIN_DIR)
+- install -s $(BIN) $(DESTDIR)$(BIN_DIR)
++ install $(BIN) $(DESTDIR)$(BIN_DIR)
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb
new file mode 100644
index 0000000000..80b3c9a3b1
--- /dev/null
+++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities_20040406.bb
@@ -0,0 +1,26 @@
+SECTION = "console/utils"
+DESCRIPTION = "Utilities for User-Mode-Linux"
+LICENSE = "GPL-2.0"
+DEPENDS = "zlib ncurses readline"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+SRC_URI = "http://downloads.sourceforge.net/project/user-mode-linux/tools/1/uml_utilities_${PV}.tar.bz2 \
+ file://fix-ldflags.patch \
+ file://unstrip.patch \
+ "
+SRC_URI[md5sum] = "2c1ccd9efacbfb39e42d482b89b2550a"
+SRC_URI[sha256sum] = "4f179b1db021ef15ac7e9b2eed57c525db127a754c574f591c367460cded9f41"
+
+PR = "r1"
+
+S = "${WORKDIR}/tools"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+FILES_${PN} += "${libdir}"
+FILES_${PN}-dbg += "${libdir}/uml/.debug"