aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorEric BENARD <eric@eukrea.com>2011-12-02 15:09:56 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-06 16:37:27 +0100
commitf50fc8c1962c39c97018629e59b56b65caf20ace (patch)
treee54f748bada2f2d40db9c715abf4ad6cf5a37b16 /meta-oe/recipes-extended
parent62222b77754745a4ed3087f0f2dcf01ba2592993 (diff)
downloadmeta-openembedded-f50fc8c1962c39c97018629e59b56b65caf20ace.tar.gz
atftp: correctly handle init script
else it's affected to atftp package which is the client and not the server, but the init file is only in the server package thus leading to the following log at boot : Configuring atftp. update-rc.d: /etc/init.d/atftpd: file does not exist while at it, there is a cosmetic change from _atftpd to _${PN}d to make the recipe consistent Signed-off-by: Eric BĂ©nard <eric@eukrea.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/atftp/atftp_0.7.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/atftp/atftp_0.7.bb b/meta-oe/recipes-extended/atftp/atftp_0.7.bb
index c5416341f2..ab14a28427 100644
--- a/meta-oe/recipes-extended/atftp/atftp_0.7.bb
+++ b/meta-oe/recipes-extended/atftp/atftp_0.7.bb
@@ -3,6 +3,7 @@ SECTION = "network"
HOMEPAGE = "http://packages.debian.org/atftp"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://LICENSE;md5=94d55d512a9ba36caa9b7df079bae19f"
+PR = "r1"
SRC_URI = "${DEBIAN_MIRROR}/main/a/atftp/atftp_${PV}.dfsg.orig.tar.gz;name=archive \
${DEBIAN_MIRROR}/main/a/atftp/atftp_${PV}.dfsg-11.diff.gz;name=patch \
@@ -16,11 +17,12 @@ inherit autotools update-rc.d systemd useradd
SYSTEMD_PACKAGES = "atftpd-systemd"
SYSTEMD_SERVICE_atftpd-systemd = "atftpd.service"
-INITSCRIPT_NAME = "atftpd"
-INITSCRIPT_PARAMS = "defaults 80"
+INITSCRIPT_PACKAGES = "${PN}d"
+INITSCRIPT_NAME_${PN}d = "atftpd"
+INITSCRIPT_PARAMS_${PN}d = "defaults 80"
-USERADD_PACKAGES = "atftpd"
-USERADD_PARAM_atftpd = "--system --no-create-home --shell /bin/false \
+USERADD_PACKAGES = "${PN}d"
+USERADD_PARAM_${PN}d = "--system --no-create-home --shell /bin/false \
--user-group nobody"
do_install_append() {