aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-19 16:33:15 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit505774658338002a92c2e32c4c57c55f36c5e36e (patch)
treec5d1032aac37af7493141cdfa56da5b371ce5a59 /meta-oe/recipes-extended
parent66454b26ff49c6cca3dd8d32832078cfa05cd5ef (diff)
downloadmeta-openembedded-505774658338002a92c2e32c4c57c55f36c5e36e.tar.gz
meta-oe: Remove using python2
This change makes the parsing go though, we still might have build issues, which will be reported in world builds seprately Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/collectd/collectd_5.8.1.bb2
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.12.6.bb2
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_0.6.bb8
-rw-r--r--meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb2
-rw-r--r--meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb4
-rw-r--r--meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb2
6 files changed, 10 insertions, 10 deletions
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb b/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb
index 0951ac076f..8b9fd74a87 100644
--- a/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb
+++ b/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb
@@ -19,7 +19,7 @@ SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \
SRC_URI[md5sum] = "bfce96c42cede5243028510bcc57c1e6"
SRC_URI[sha256sum] = "e796fda27ce06377f491ad91aa286962a68c2b54076aa77a29673d53204453da"
-inherit autotools pythonnative update-rc.d pkgconfig systemd
+inherit autotools python3native update-rc.d pkgconfig systemd
SYSTEMD_SERVICE_${PN} = "collectd.service"
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
index 77c995b57a..765a84643e 100644
--- a/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
+++ b/meta-oe/recipes-extended/hplip/hplip_3.12.6.bb
@@ -14,7 +14,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
DEPENDS += "cups python libusb"
-inherit autotools-brokensep python-dir pythonnative pkgconfig
+inherit autotools-brokensep python3-dir python3native pkgconfig
export STAGING_INCDIR
export STAGING_LIBDIR
diff --git a/meta-oe/recipes-extended/iotop/iotop_0.6.bb b/meta-oe/recipes-extended/iotop/iotop_0.6.bb
index b01d7f64e6..68cc352249 100644
--- a/meta-oe/recipes-extended/iotop/iotop_0.6.bb
+++ b/meta-oe/recipes-extended/iotop/iotop_0.6.bb
@@ -15,13 +15,13 @@ SRC_URI[sha256sum] = "3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8d
UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
-inherit distutils
+inherit distutils3
do_install_append() {
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
}
-RDEPENDS_${PN} = "python-curses python-textutils \
- python-codecs python-ctypes python-pprint \
- python-shell python-subprocess python-core"
+RDEPENDS_${PN} = "python3-curses python3-textutils \
+ python3-codecs python3-ctypes python3-pprint \
+ python3-shell python3-subprocess python3-core"
diff --git a/meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb b/meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb
index 48dec47a81..4a8d9a1df0 100644
--- a/meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb
+++ b/meta-oe/recipes-extended/libimobiledevice/libplist_2.1.0.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ebb5c50ab7cab4baeffba14977030c07 \
DEPENDS = "libxml2 glib-2.0 swig python"
-inherit autotools pkgconfig pythonnative
+inherit autotools pkgconfig python3native
SRCREV = "3df02d4d0e9008771e8622fdc10de8333b3f0d85"
SRC_URI = "git://github.com/libimobiledevice/libplist;protocol=https \
diff --git a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
index 419b3ee6e8..754476d67b 100644
--- a/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
+++ b/meta-oe/recipes-extended/openlmi/openlmi-tools_0.10.5.bb
@@ -5,9 +5,9 @@ LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e"
SECTION = "System/Management"
-inherit setuptools
+inherit setuptools3
-DEPENDS = "python-native python-pywbem-native python-m2crypto python-pywbem"
+DEPENDS = "python3-native python3-pywbem-native python3-m2crypto python-pywbem"
SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
"
diff --git a/meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb b/meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb
index b39ceda80b..c7dbb6e39e 100644
--- a/meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb
+++ b/meta-oe/recipes-extended/rrdtool/rrdtool_1.7.2.bb
@@ -15,7 +15,7 @@ SRC_URI = "\
S = "${WORKDIR}/git"
-inherit cpan autotools-brokensep gettext pythonnative python-dir systemd
+inherit cpan autotools-brokensep gettext python3native python3-dir systemd
BBCLASSEXTEND = "native"