aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorDiego Rondini <diego.rondini@kynetics.com>2020-09-10 21:09:56 +0200
committerArmin Kuster <akuster808@gmail.com>2020-11-09 19:43:29 -0800
commit636daeba35c5b9ec8e570225353a78c591c98756 (patch)
treeb6512acc79efacbe4691a48f455af47ed33fdf2c /meta-oe/recipes-extended
parentd89968b63f16f49ff04f37dbfb55fb078f5f2541 (diff)
downloadmeta-openembedded-636daeba35c5b9ec8e570225353a78c591c98756.tar.gz
hplip: use libexecdir
In oe-core commit: 2ce6ef29b9bb4f16ed9d78e166d455b7a6d968bf cups crossscripts have been fixed to report the correct serverbin folder, so backend, filters, etc, need to go in ${libexecdir} now. Signed-off-by: Diego Rondini <diego.rondini@kynetics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit db7fc115e058e2e0e481e284768538f097cfdd90) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/hplip/hplip_3.19.12.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/hplip/hplip_3.19.12.bb b/meta-oe/recipes-extended/hplip/hplip_3.19.12.bb
index 883a6ffe95..457a974534 100644
--- a/meta-oe/recipes-extended/hplip/hplip_3.19.12.bb
+++ b/meta-oe/recipes-extended/hplip/hplip_3.19.12.bb
@@ -39,8 +39,8 @@ EXTRA_OECONF += "\
--enable-foomatic-drv-install \
--disable-foomatic-ppd-install \
--disable-foomatic-rip-hplip-install \
- --with-cupsbackenddir=${libdir}/cups/backend \
- --with-cupsfilterdir=${libdir}/cups/filter \
+ --with-cupsbackenddir=${libexecdir}/cups/backend \
+ --with-cupsfilterdir=${libexecdir}/cups/filter \
"
EXTRA_OEMAKE = "rulessystemdir=${systemd_unitdir}/system/"
@@ -52,7 +52,7 @@ do_install_append() {
sed -i -e "s|/usr/bin/python|/usr/bin/env python3|g" ${D}${datadir}/hplip/*.py
}
-PACKAGES += "${PN}-ppd ${PN}-cups ${PN}-backend ${PN}-filter ${PN}-hal"
+PACKAGE_BEFORE_PN += "${PN}-ppd ${PN}-cups ${PN}-backend ${PN}-filter ${PN}-hal"
RDEPENDS_${PN} += " \
python3\
@@ -70,15 +70,15 @@ RDEPENDS_${PN}-filter += "perl"
# need to snag the debug file or OE will fail on backend package
FILES_${PN}-dbg += "\
- ${libdir}/cups/backend/.debug \
+ ${libexecdir}/cups/backend/.debug \
${PYTHON_SITEPACKAGES_DIR}/.debug \
- ${libdir}/cups/filter/.debug "
+ ${libexecdir}/cups/filter/.debug "
FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la"
FILES_${PN}-ppd = "${datadir}/ppd"
FILES_${PN}-cups = "${datadir}/cups"
-FILES_${PN}-backend = "${libdir}/cups/backend"
-FILES_${PN}-filter = "${libdir}/cups/filter"
+FILES_${PN}-backend = "${libexecdir}/cups/backend"
+FILES_${PN}-filter = "${libexecdir}/cups/filter"
FILES_${PN}-hal = "${datadir}/hal"
FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/*.so"