aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2015-08-25 13:19:53 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:11:11 +0200
commit3aa61fb9512449477546320ec46cebf7e39daed0 (patch)
tree726bafd0a62b0f6755df892718469736ade7a95d /meta-oe/recipes-extended
parentb7003eb198d22d46ef7d24932b5371a7d15e1152 (diff)
downloadmeta-openembedded-3aa61fb9512449477546320ec46cebf7e39daed0.tar.gz
sblim-sfcCommon: add new recipe
Sblim-sfcCommon is dependence of sblim-sfcb. Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/sblim-sfcCommon/sblim-sfcCommon_1.0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcCommon/sblim-sfcCommon_1.0.1.bb b/meta-oe/recipes-extended/sblim-sfcCommon/sblim-sfcCommon_1.0.1.bb
new file mode 100644
index 0000000000..0f5515aea2
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcCommon/sblim-sfcCommon_1.0.1.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Common functions for SBLIM Small Footprint CIM Broker and CIM Client Library."
+DESCRIPTION = "\
+This package provides a common library for functions shared between Small Footprint CIM Broker (sblim-sfcb) \
+Small Footprint CIM Client (and sblim-sfcc)."
+HOMEPAGE = "http://sourceforge.net/projects/sblim/"
+LICENSE = "EPL"
+LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
+SECTION = "Development/Libraries"
+
+DEPENDS = "cmpi-bindings"
+
+SRC_URI = "http://downloads.sourceforge.net/sblim/${PN}-${PV}.tar.bz2 \
+ "
+SRC_URI[md5sum] = "8aa2655d97bdea54c4750f220b40990c"
+SRC_URI[sha256sum] = "b9b1037173d6ae0181c3bd5a316ddab5afd6a342ad0dbdc18e940fc0ad2c3297"
+
+inherit autotools
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+
+ rm -rf ${D}${libdir}/libsfcUtil.a
+ rm -rf ${D}${libdir}/libsfcUtil.la
+}
+