aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-24 20:56:27 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:32 +0200
commit91df32a7901c64164fb70bf4f070579f75c71397 (patch)
treecaa8e73dfe88e2dc22ea9e6f44580d988b29473e /meta-oe/recipes-extended
parent0d71705498e559c8fa45d41ffc4e0c7d2eed2db0 (diff)
downloadmeta-openembedded-91df32a7901c64164fb70bf4f070579f75c71397.tar.gz
efibootmgr: Upgrade to 0.15
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch49
-rw-r--r--meta-oe/recipes-extended/efibootmgr/efibootmgr_0.15.bb (renamed from meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb)13
2 files changed, 6 insertions, 56 deletions
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch b/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch
deleted file mode 100644
index b6211c28a1..0000000000
--- a/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From a9f8d414972b0b7c963d7efe38b5cfdcb6413c46 Mon Sep 17 00:00:00 2001
-From: Peter Jones <pjones@redhat.com>
-Date: Mon, 6 Feb 2017 16:34:54 -0500
-Subject: [PATCH] Remove extra const keywords gcc 7 gripes about.
-
-Signed-off-by: Peter Jones <pjones@redhat.com>
----
- src/efibootdump.c | 2 +-
- src/efibootmgr.c | 4 ++--
- 2 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/efibootdump.c b/src/efibootdump.c
-index 3e448c2..5a9b681 100644
---- a/src/efibootdump.c
-+++ b/src/efibootdump.c
-@@ -36,7 +36,7 @@ print_boot_entry(efi_load_option *loadopt, size_t data_size)
- uint8_t *optional_data = NULL;
- size_t optional_data_len = 0;
- uint16_t pathlen;
-- const unsigned char const *desc;
-+ const unsigned char *desc;
- char *raw;
- size_t raw_len;
-
-diff --git a/src/efibootmgr.c b/src/efibootmgr.c
-index baefa68..683623b 100644
---- a/src/efibootmgr.c
-+++ b/src/efibootmgr.c
-@@ -214,7 +214,7 @@ warn_duplicate_name(list_t *boot_list)
- list_t *pos;
- var_entry_t *boot;
- efi_load_option *load_option;
-- const unsigned char const *desc;
-+ const unsigned char *desc;
-
- list_for_each(pos, boot_list) {
- boot = list_entry(pos, var_entry_t, list);
-@@ -821,7 +821,7 @@ show_boot_vars()
- {
- list_t *pos;
- var_entry_t *boot;
-- const unsigned char const *description;
-+ const unsigned char *description;
- efi_load_option *load_option;
- efidp dp = NULL;
- unsigned char *optional_data = NULL;
---
-2.12.2
-
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.15.bb
index 193150bb9f..9cc62a9591 100644
--- a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb
+++ b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.15.bb
@@ -10,19 +10,18 @@ DEPENDS = "pciutils zlib efivar"
COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
-SRCREV = "75d25807ba81cb724964c989012611272c8f1f5d"
+SRCREV = "5c14da22802576a99ebb854f7aa174f796f7b031"
SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \
- file://0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch \
"
-
S = "${WORKDIR}/git"
-
inherit pkgconfig
-EXTRA_OEMAKE = "'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar` \
- -DEFIBOOTMGR_VERSION=\"$(RELEASE_MAJOR).$(RELEASE_MINOR)\" '"
+EXTRA_OEMAKE = "'EFIDIR=/' 'CC=${CC}' 'CFLAGS=${CFLAGS} -I${S}/src/include `pkg-config --cflags efivar`'"
+CFLAGS_append_toolchain-clang = " -Wno-error"
do_install () {
- install -D -p -m0755 src/efibootmgr ${D}/${sbindir}/efibootmgr
+ install -D -p -m0755 ${B}/src/efibootmgr ${D}/${sbindir}/efibootmgr
}
+
+CLEANBROKEN = "1"