aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-09-25 21:19:07 +0800
committerKhem Raj <raj.khem@gmail.com>2018-09-25 22:24:15 -0700
commite46ed5b414d617a20c1e6cd78e50915e960fffd8 (patch)
treedbb4964a44a97f57de7f4f5a46ff418c0df58962 /meta-oe/recipes-extended
parent23d794b58661807307a3c4af3f3da1fc1027f41b (diff)
downloadmeta-openembedded-e46ed5b414d617a20c1e6cd78e50915e960fffd8.tar.gz
mailx: support openssl 1.1.x
Long time no maintain from upstream since 2013-06-04, backport a fix from openSUSE Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/mailx/files/0001-support-openssl-1.1.x.patch72
-rw-r--r--meta-oe/recipes-extended/mailx/mailx_12.5-5.bb3
2 files changed, 74 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/mailx/files/0001-support-openssl-1.1.x.patch b/meta-oe/recipes-extended/mailx/files/0001-support-openssl-1.1.x.patch
new file mode 100644
index 0000000000..6a8911daf7
--- /dev/null
+++ b/meta-oe/recipes-extended/mailx/files/0001-support-openssl-1.1.x.patch
@@ -0,0 +1,72 @@
+From 7db6d8a657d13bb562a27c6181accaf3e53c0efd Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Tue, 25 Sep 2018 14:03:10 +0800
+Subject: [PATCH] support openssl 1.1.x
+
+Long time no maintain from upstream since 2013-06-04
+(https://sourceforge.net/projects/nail/), backport a
+fix from openSUSE
+
+Upstream-Status: Backport [openSUSE]
+https://build.opensuse.org/package/view_file/openSUSE:Leap:15.0/mailx/mailx-12.5-openssl-1.1.0f.patch?expand=1
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ openssl.c | 25 ++++++++++++++++++++++++-
+ 1 file changed, 24 insertions(+), 1 deletion(-)
+
+diff --git a/openssl.c b/openssl.c
+index 44fe4e5..0ccc517 100644
+--- a/openssl.c
++++ b/openssl.c
+@@ -137,7 +137,12 @@ ssl_rand_init(void)
+
+ if ((cp = value("ssl-rand-egd")) != NULL) {
+ cp = expand(cp);
+- if (RAND_egd(cp) == -1) {
++#ifndef OPENSSL_NO_EGD
++ if (RAND_egd(cp) == -1)
++#else
++ if (1)
++#endif
++ {
+ fprintf(stderr, catgets(catd, CATSET, 245,
+ "entropy daemon at \"%s\" not available\n"),
+ cp);
+@@ -216,6 +221,7 @@ ssl_select_method(const char *uhp)
+
+ cp = ssl_method_string(uhp);
+ if (cp != NULL) {
++#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x1010006fL
+ if (equal(cp, "ssl3"))
+ method = SSLv3_client_method();
+ else if (equal(cp, "tls1"))
+@@ -225,8 +231,25 @@ ssl_select_method(const char *uhp)
+ "Invalid SSL method \"%s\"\n"), cp);
+ method = SSLv23_client_method();
+ }
++#else
++ method = NULL;
++ if (equal(cp, "tls"))
++ method = TLS_client_method();
++ else if (equal(cp, "dtls"))
++ method = DTLS_client_method();
++
++ if (!method) {
++ fprintf(stderr, catgets(catd, CATSET, 244,
++ "Invalid SSL method \"%s\"\n"), cp);
++ method = TLS_client_method();
++ }
++#endif
+ } else
++#if defined(OPENSSL_VERSION_NUMBER) && OPENSSL_VERSION_NUMBER < 0x1010006fL
+ method = SSLv23_client_method();
++#else
++ method = TLS_client_method();
++#endif
+ return method;
+ }
+
+--
+2.7.4
+
diff --git a/meta-oe/recipes-extended/mailx/mailx_12.5-5.bb b/meta-oe/recipes-extended/mailx/mailx_12.5-5.bb
index 0a191a00c1..4161ea6750 100644
--- a/meta-oe/recipes-extended/mailx/mailx_12.5-5.bb
+++ b/meta-oe/recipes-extended/mailx/mailx_12.5-5.bb
@@ -9,7 +9,7 @@ SECTION = "console/network"
LICENSE = "BSD & MPL-1"
LIC_FILES_CHKSUM = "file://COPYING;md5=4202a0a62910cf94f7af8a3436a2a2dd"
-DEPENDS = "openssl10"
+DEPENDS = "openssl"
SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/h/heirloom-mailx/heirloom-mailx_12.5.orig.tar.gz;name=archive \
file://0001-Don-t-reuse-weak-symbol-optopt-to-fix-FTBFS-on-mips.patch \
@@ -21,6 +21,7 @@ SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/
file://0014-globname-Invoke-wordexp-with-WRDE_NOCMD.patch \
file://0015-usr-sbin-sendmail.patch \
file://explicitly.disable.krb5.support.patch \
+ file://0001-support-openssl-1.1.x.patch \
"
SRC_URI[archive.md5sum] = "29a6033ef1412824d02eb9d9213cb1f2"