aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/glm
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2017-03-06 19:06:23 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-11 17:56:41 +0100
commit07b5b960207271fdaeab67f9775fd7acb4c10e8a (patch)
tree2187ebe677254aaa2844c5948945789f43ef78bf /meta-oe/recipes-graphics/glm
parente386a9a6c4ffc9204011162f73ffa3d69f733bc5 (diff)
downloadmeta-openembedded-07b5b960207271fdaeab67f9775fd7acb4c10e8a.tar.gz
glm: Add recipe for OpenGL Mathematics library
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/glm')
-rw-r--r--meta-oe/recipes-graphics/glm/glm_0.9.8.4.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/glm/glm_0.9.8.4.bb b/meta-oe/recipes-graphics/glm/glm_0.9.8.4.bb
new file mode 100644
index 0000000000..2a78c46f5b
--- /dev/null
+++ b/meta-oe/recipes-graphics/glm/glm_0.9.8.4.bb
@@ -0,0 +1,21 @@
+SUMMARY = "OpenGL Mathematics Library"
+DESCRIPTION = "OpenGL Mathematics (GLM) is a header only C++ \
+mathematics library for graphics software based on the OpenGL \
+Shading Language (GLSL) specifications."
+HOMEPAGE = "https://glm.g-truc.net"
+BUGTRACKER = "https://github.com/g-truc/glm/issues"
+
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://copying.txt;md5=4431606d144252143c9c3df384a74cad"
+
+SRC_URI = "git://github.com/g-truc/glm;protocol=https"
+
+SRCREV = "5dcc56489e1b66dfd5bca751fa9b8dc68059e008"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_${PN}-dev += "${libdir}/cmake"