aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-03-05 16:43:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-10 14:19:37 +0100
commit800a0906c7a322f6c01e054901228fd5a10c36bd (patch)
treeb94a1e308bdb3450bcd5297bac9550876cd970e3 /meta-oe/recipes-kernel/ktap/ktap-module_git.bb
parentbdac062c685f40fe07e5d799d7486f347fe8976a (diff)
downloadmeta-openembedded-800a0906c7a322f6c01e054901228fd5a10c36bd.tar.gz
ktap: rename recipes to indicate they are from git
* set PV so that it shows git revision and also automatically rebuilds them when SRCREV is changed Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap-module_git.bb')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
new file mode 100644
index 0000000000..62f2a99a25
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
@@ -0,0 +1,22 @@
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require ktap.inc
+
+SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
+
+inherit module
+
+# Available package configs: ffi (only supported on x86_64)
+PACKAGECONFIG ?= ""
+
+# Only build the module
+MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod"
+
+# Kernel module packages MUST begin with 'kernel-module-', otherwise
+# multilib image generation can fail.
+#
+# The following line is only necessary if the recipe name does not begin
+# with kernel-module-.
+#
+PKG_${PN} = "kernel-module-${PN}"
+