aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-03-05 16:43:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-10 14:19:37 +0100
commit800a0906c7a322f6c01e054901228fd5a10c36bd (patch)
treeb94a1e308bdb3450bcd5297bac9550876cd970e3 /meta-oe/recipes-kernel/ktap/ktap_git.bb
parentbdac062c685f40fe07e5d799d7486f347fe8976a (diff)
downloadmeta-openembedded-800a0906c7a322f6c01e054901228fd5a10c36bd.tar.gz
ktap: rename recipes to indicate they are from git
* set PV so that it shows git revision and also automatically rebuilds them when SRCREV is changed Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap_git.bb')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap_git.bb b/meta-oe/recipes-kernel/ktap/ktap_git.bb
new file mode 100644
index 0000000000..cbdabf82d8
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap_git.bb
@@ -0,0 +1,26 @@
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require ktap.inc
+
+SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
+DEPENDS = "ktap-module"
+
+#Available package configs:
+# libelf - needed to resolve symbols in DSO and for sdt
+# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
+PACKAGECONFIG ?= "libelf"
+
+PACKAGECONFIG[libelf] = ",,elfutils"
+
+# Only build the userspace app
+EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
+ ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
+ ktap"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/ktap ${D}${bindir}/
+}
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+RDEPENDS_${PN} = "kernel-module-ktapvm"