aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-09 12:26:29 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-04 14:50:23 +0100
commit6c4cb0fb00c9b8e68ed39c87370c841deec30acf (patch)
treed64323b896cab45d097ac9bef335d9d53d9b6a40 /meta-oe/recipes-kernel/ktap
parent220b31d536cf15e68c11980e0c721a7050313db1 (diff)
downloadmeta-openembedded-6c4cb0fb00c9b8e68ed39c87370c841deec30acf.tar.gz
ktap: add libelf PACKAGECONFIG also to ktap-module
* building ktap-module without elfutils fails with: ktap-module/0.4-r0/git/Makefile:107: No libelf found, disables symbol resolving, please install elfutils-libelf-devel/libelf-dev Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/ktap')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_git.bb5
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc12
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_git.bb10
3 files changed, 14 insertions, 13 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
index e3c94e3dc7..cb913271f6 100644
--- a/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_git.bb
@@ -9,11 +9,8 @@ inherit module
# See https://github.com/ktap/ktap/issues/80
PNBLACKLIST[ktap-module] ?= "Not compatible with 3.19 kernel"
-# Available package configs: ffi (only supported on x86_64)
-PACKAGECONFIG ?= ""
-
# Only build the module
-MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod"
+MAKE_TARGETS = "mod"
# Kernel module packages MUST begin with 'kernel-module-', otherwise
# multilib image generation can fail.
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
index 2c94a08d64..e2e498f9f5 100644
--- a/meta-oe/recipes-kernel/ktap/ktap.inc
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -11,4 +11,16 @@ SRC_URI = "git://github.com/ktap/ktap.git"
S = "${WORKDIR}/git"
# Package config is abused as a general compile time configuration tool.
+
+# Only supports x86_64 for now!. Needs to be enabled for ktap-module too.
PACKAGECONFIG[ffi] = ""
+
+# Needed to resolve symbols in DSO and for sdt
+PACKAGECONFIG[libelf] = ",,elfutils"
+
+PACKAGECONFIG ?= "libelf"
+
+EXTRA_OEMAKE = " \
+ ${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
+ ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
+"
diff --git a/meta-oe/recipes-kernel/ktap/ktap_git.bb b/meta-oe/recipes-kernel/ktap/ktap_git.bb
index 1379c48334..248e7bdd66 100644
--- a/meta-oe/recipes-kernel/ktap/ktap_git.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap_git.bb
@@ -6,17 +6,9 @@ SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
DEPENDS = "ktap-module"
PNBLACKLIST[ktap] ?= "Depends on blacklisted kernel-module-ktapvm"
-#Available package configs:
-# libelf - needed to resolve symbols in DSO and for sdt
-# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
-PACKAGECONFIG ?= "libelf"
-
-PACKAGECONFIG[libelf] = ",,elfutils"
# Only build the userspace app
-EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
- ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
- ktap"
+EXTRA_OEMAKE += "ktap"
do_install() {
install -d ${D}${bindir}