aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/pm-graph
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-18 11:22:31 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-18 20:52:00 -0800
commit696408ce3661b663a7895f75a01613e6cfeb8186 (patch)
treeba8fc3f702b630274e586ba8ad2fe3fc0591ae65 /meta-oe/recipes-kernel/pm-graph
parentc90be40eb9f4028368ab5030e7f9a78d05707572 (diff)
downloadmeta-openembedded-696408ce3661b663a7895f75a01613e6cfeb8186.tar.gz
pm-graph: Provide analyze-suspend as well
Remove stale analyze-suspend recipe Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/pm-graph')
-rw-r--r--meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
index 63a9fa88e9..a1378866ad 100644
--- a/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
+++ b/meta-oe/recipes-kernel/pm-graph/pm-graph_5.5.bb
@@ -12,11 +12,22 @@ SRC_URI = "git://github.com/intel/pm-graph.git \
"
S = "${WORKDIR}/git"
+# Apart from the listed RDEPENDS, analyze-suspend depends on some features
+# provided by the kernel. These options are:
+# - CONFIG_PM_DEBUG=y
+# - CONFIG_PM_SLEEP_DEBUG=y
+# - CONFIG_FTRACE=y
+# - CONFIG_FUNCTION_TRACER=y
+# - CONFIG_FUNCTION_GRAPH_TRACER=y
+
COMPATIBLE_HOST='(i.86|x86_64).*'
EXTRA_OEMAKE = "PREFIX=${prefix} DESTDIR=${D} BASELIB=${baselib}"
do_install() {
oe_runmake install
+ install -Dm 0755 ${S}/analyze_suspend.py ${D}${bindir}/analyze_suspend.py
}
RDEPENDS_${PN} += "python3-core python3-threading python3-datetime python3-compression"
+RPROVIDES_${PN} = "analyze-suspend"
+BBCLASSEXTEND = "native nativesdk"