aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2014-01-10 07:47:51 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-01-15 18:02:32 +0100
commit3e79b4c4e1653fc5471c1a2ef815d143644dba14 (patch)
treebb49c6b9fff4bac464d1129d3d0d30e2f9ea2475 /meta-oe/recipes-kernel
parentd4b25acb2db4e11f65b588b748ff12f47ba502ca (diff)
downloadmeta-openembedded-3e79b4c4e1653fc5471c1a2ef815d143644dba14.tar.gz
ktap: add configs for elfutils and ffi
libelf (elfutils) is required for resolving symbols in DSO and for sdt (taken from ktap docs). The earlier v0.4 recipe built ktap against libelf if it was found, thus enable it per default. FFI needs to be enabled for both userspace and kernel module. Currently, it is only supported for x86_64 (enforced when building ktap-module). Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb5
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc2
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb11
3 files changed, 16 insertions, 2 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
index 12167ea16c..ce6885cbb7 100644
--- a/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_0.4.bb
@@ -6,8 +6,11 @@ DESCRIPTION = "KTAP is a scripting dynamic tracing tool for Linux"
inherit module
+# Available package configs: ffi (only supported on x86_64)
+PACKAGECONFIG ?= ""
+
# Only build the module
-MAKE_TARGETS = "mod"
+MAKE_TARGETS = "${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} mod"
# Kernel module packages MUST begin with 'kernel-module-', otherwise
# multilib image generation can fail.
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
index 7e60453767..93a4e2ca32 100644
--- a/meta-oe/recipes-kernel/ktap/ktap.inc
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -9,3 +9,5 @@ SRC_URI = "git://github.com/ktap/ktap.git"
S = "${WORKDIR}/git"
+# Package config is abused as a general compile time configuration tool.
+PACKAGECONFIG[ffi] = ""
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
index f5dd62f849..20f94d5980 100644
--- a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -5,8 +5,17 @@ require ktap.inc
SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
DEPENDS = "ktap-module"
+#Available package configs:
+# libelf - needed to resolve symbols in DSO and for sdt
+# ffi - only supports x86_64 for now!. Needs to be enabled for ktap-module too.
+PACKAGECONFIG ?= "libelf"
+
+PACKAGECONFIG[libelf] = ",,elfutils"
+
# Only build the userspace app
-EXTRA_OEMAKE = "ktap"
+EXTRA_OEMAKE = "${@base_contains('PACKAGECONFIG', 'libelf', '', 'NO_LIBELF=1', d)} \
+ ${@base_contains('PACKAGECONFIG', 'ffi', 'FFI=1', '', d)} \
+ ktap"
do_install() {
install -d ${D}${bindir}