aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/esound
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-03 19:39:02 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-03 19:39:02 +0200
commit0afca575ee4b4be846db3ed4a4f25383ddfecaac (patch)
treea9e1d5fea82429ccc1c66254831009fcf6153f1a /meta-oe/recipes-multimedia/esound
parent821c42c7f95a9d12de38e4153514f99f4d3323ca (diff)
downloadmeta-openembedded-0afca575ee4b4be846db3ed4a4f25383ddfecaac.tar.gz
esound import from OE rev 7ae56b81f8cc22f9ef13a48cde000e32138948ea
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-multimedia/esound')
-rw-r--r--meta-oe/recipes-multimedia/esound/esound_0.2.36.bb33
-rw-r--r--meta-oe/recipes-multimedia/esound/files/configure-fix.patch10
-rw-r--r--meta-oe/recipes-multimedia/esound/files/no-docs.patch11
3 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/esound/esound_0.2.36.bb b/meta-oe/recipes-multimedia/esound/esound_0.2.36.bb
new file mode 100644
index 0000000000..e020fd81f2
--- /dev/null
+++ b/meta-oe/recipes-multimedia/esound/esound_0.2.36.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Enlightened Sound Daemon"
+SECTION = "gpe/base"
+LICENSE = "LGPLv2"
+LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
+DEPENDS = "audiofile"
+
+inherit gnome binconfig
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/esound/0.2/esound-0.2.36.tar.bz2;name=archive \
+ https://launchpad.net/ubuntu/breezy/+source/esound/0.2.36-1ubuntu5/+files/esound_0.2.36-1ubuntu5.diff.gz;name=patch \
+ file://no-docs.patch \
+ file://configure-fix.patch"
+
+SRC_URI[archive.md5sum] = "3facb5aa0115cc1c31771b9ad454ae76"
+SRC_URI[archive.sha256sum] = "68bf399fcbd45c5e9ba99cd13a3a479e4ef2bc5dc52e540ffa00aef1e1b19a76"
+SRC_URI[patch.md5sum] = "44b4d713387fb3f18666d289f88ae00c"
+SRC_URI[patch.sha256sum] = "9bd7db657b8e9622910b9d3188096e37ee627ac0651c78ddce58e205e7487932
+
+EXTRA_OECONF = " \
+ --disable-alsa \
+ --disable-arts \
+ --disable-artstest \
+"
+do_configure_prepend() {
+ sed -i -e 's:/usr/include/mme:${STAGING_INCDIR}/mme:g' configure.ac
+}
+
+PACKAGES =+ "esddsp esd esd-utils"
+
+FILES_esddsp = "${bindir}/esddsp ${libdir}/libesddsp.so.*"
+FILES_esd = "${bindir}/esd"
+FILES_esd-utils = "${bindir}/*"
+
diff --git a/meta-oe/recipes-multimedia/esound/files/configure-fix.patch b/meta-oe/recipes-multimedia/esound/files/configure-fix.patch
new file mode 100644
index 0000000000..8fdc35ad5e
--- /dev/null
+++ b/meta-oe/recipes-multimedia/esound/files/configure-fix.patch
@@ -0,0 +1,10 @@
+--- /tmp/configure.ac 2008-06-02 16:46:55.640793306 +0200
++++ esound-0.2.36/configure.ac 2008-06-02 16:47:26.030793494 +0200
+@@ -29,6 +29,7 @@
+ AC_SUBST(pkgdocdir)
+
+ AC_PROG_CC
++AC_PROG_CXX
+ AC_PROG_CPP
+ AC_LIBTOOL_WIN32_DLL
+ AM_PROG_LIBTOOL
diff --git a/meta-oe/recipes-multimedia/esound/files/no-docs.patch b/meta-oe/recipes-multimedia/esound/files/no-docs.patch
new file mode 100644
index 0000000000..fc69f1a038
--- /dev/null
+++ b/meta-oe/recipes-multimedia/esound/files/no-docs.patch
@@ -0,0 +1,11 @@
+Index: esound-0.2.36/Makefile.am
+===================================================================
+--- esound-0.2.36.orig/Makefile.am
++++ esound-0.2.36/Makefile.am
+@@ -1,5 +1,5 @@
+
+-SUBDIRS = docs
++SUBDIRS =
+
+ ACLOCAL_FLAGS = -I m4
+