aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2013-02-11 18:57:05 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-16 05:54:59 +0100
commit99481803dd879b29e98bbff18cfc721102119564 (patch)
treef51acb3a39b150decbb4ab71367950ba2563caae /meta-oe/recipes-multimedia
parent49851b1190307524014e2645105b902657c46038 (diff)
downloadmeta-openembedded-99481803dd879b29e98bbff18cfc721102119564.tar.gz
x264: Add patch to remove default flags -mcpu=cortex-a8 and -mfpu=neon
-march flag is not in CFLAGS so this will always default to -mcpu=cortex-a8 -mfpu=neon. Obviously wrong for other machines. Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch20
-rw-r--r--meta-oe/recipes-multimedia/x264/x264_git.bb6
2 files changed, 25 insertions, 1 deletions
diff --git a/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch b/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
new file mode 100644
index 0000000000..b844d88fe8
--- /dev/null
+++ b/meta-oe/recipes-multimedia/x264/x264/don-t-default-to-cortex-a9-with-neon.patch
@@ -0,0 +1,20 @@
+-march flag is not in CFLAGS so this will always default to -mcpu=cortex-a8
+-mfpu=neon.
+
+Upstream-Status: Pending
+Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
+
+Index: git/configure
+===================================================================
+--- git.orig/configure 2013-02-10 16:26:40.666343682 +0200
++++ git/configure 2013-02-10 16:27:49.198341677 +0200
+@@ -703,9 +703,6 @@
+ fi
+
+ if [ $asm = auto -a $ARCH = ARM ] ; then
+- # set flags so neon is built by default
+- echo $CFLAGS | grep -Eq '(-mcpu|-march|-mfpu)' || CFLAGS="$CFLAGS -mcpu=cortex-a8 -mfpu=neon"
+-
+ if cc_check '' '' '__asm__("rev ip, ip");' ; then define HAVE_ARMV6
+ cc_check '' '' '__asm__("movt r0, #0");' && define HAVE_ARMV6T2
+ cc_check '' '' '__asm__("vadd.i16 q0, q0, q0");' && define HAVE_NEON
diff --git a/meta-oe/recipes-multimedia/x264/x264_git.bb b/meta-oe/recipes-multimedia/x264/x264_git.bb
index 7d7579f42e..056c25c41b 100644
--- a/meta-oe/recipes-multimedia/x264/x264_git.bb
+++ b/meta-oe/recipes-multimedia/x264/x264_git.bb
@@ -4,9 +4,13 @@ HOMEPAGE = "http://www.videolan.org/developers/x264.html"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+PR = "r1"
+
DEPENDS = "yasm-native"
-SRC_URI = "git://git.videolan.org/x264.git"
+SRC_URI = "git://git.videolan.org/x264.git \
+ file://don-t-default-to-cortex-a9-with-neon.patch \
+ "
SRCREV = "1cffe9f406cc54f4759fc9eeb85598fb8cae66c7"
PV = "r2230+git"