aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gpsd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-04-24 17:46:06 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-04-29 23:29:33 +0200
commitc11555a5906577ce02d5569023d2025548334839 (patch)
tree20dabfe4af532447b1fbeda55f01a2373722337e /meta-oe/recipes-navigation/gpsd
parentc09342fd6cc4644eb8114bdd2f004856c8546d50 (diff)
downloadmeta-openembedded-c11555a5906577ce02d5569023d2025548334839.tar.gz
gpsd: replace whole do_install from scons.bbclass
* prefix was wrong, because SConstruct expects prefix usable as RPATH and DESTDIR not DESTDIR/prefix combined together in prefix variable Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
index d139091fdc..fae3492401 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.4.bb
@@ -46,13 +46,18 @@ do_compile_prepend() {
export HOST_SYS="${HOST_SYS}"
}
-do_install_prepend() {
+do_install() {
export PKG_CONFIG_PATH="${PKG_CONFIG_PATH}"
export PKG_CONFIG="PKG_CONFIG_SYSROOT_DIR=\"${PKG_CONFIG_SYSROOT_DIR}\" pkg-config"
export STAGING_PREFIX="${STAGING_DIR_HOST}/${prefix}"
export BUILD_SYS="${BUILD_SYS}"
export HOST_SYS="${HOST_SYS}"
+
+ export DESTDIR="${D}"
+ # prefix is used for RPATH and DESTDIR/prefix for instalation
+ ${STAGING_BINDIR_NATIVE}/scons prefix=${prefix} install ${EXTRA_OESCONS}|| \
+ bbfatal "scons install execution failed."
}
do_install_append() {