aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/gpsd
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:38 +0200
commit21f10c11f39020f9502d741c774a12d1aeb39499 (patch)
treefdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-navigation/gpsd
parent723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff)
downloadmeta-openembedded-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation/gpsd')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index a300595687..aef9b138ab 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -30,12 +30,12 @@ inherit scons update-rc.d python-dir pythonnative systemd bluetooth
INITSCRIPT_NAME = "gpsd"
INITSCRIPT_PARAMS = "defaults 35"
-SYSTEMD_OESCONS = "${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false',d)}"
+SYSTEMD_OESCONS = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false',d)}"
export STAGING_INCDIR
export STAGING_LIBDIR
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
PACKAGECONFIG[bluez] = "bluez='true',bluez='false',${BLUEZ}"
PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free"
EXTRA_OESCONS = " \