aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2017-11-15 13:21:36 -0800
committerArmin Kuster <akuster808@gmail.com>2017-11-19 13:41:58 -0800
commit194f855b44319c7834ba11e6e0a77ef279970a04 (patch)
tree5e4529b57523f6f378e7663a2d163144ddb18776 /meta-oe/recipes-navigation
parent5c79363f3f48575500de8e514f1f36be7c8ef494 (diff)
downloadmeta-openembedded-194f855b44319c7834ba11e6e0a77ef279970a04.tar.gz
gpsd: fix /etc/default/gpsd ALTERNATIVES logic
The ALTERNATIVES logic for the /etc/default/gpsd file is broken, specifying ALTERNATIVE_LINK without brackets. In addition, it refers to ALTERNATIVE_PATH, which update-alternatives.bbclass doesn't use. With this patch, /etc/default/gpsd correctly gets a default link pointing to /etc/default/gpsd.default. Currently, no such link gets created, and gpsd starts off disabled by default since it's missing this config file. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
index e23d63033d..26d74867bf 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.16.bb
@@ -136,6 +136,5 @@ SYSTEMD_SERVICE_${PN} = "${PN}.socket"
ALTERNATIVE_${PN} = "gpsd-defaults"
-ALTERNATIVE_PATH = "${sysconfdir}/default/gpsd.default"
-ALTERNATIVE_LINK = "${sysconfdir}/default/gpsd"
-ALTERNATIVE_TARGET = "${sysconfdir}/default/gpsd.default"
+ALTERNATIVE_LINK_NAME[gpsd-defaults] = "${sysconfdir}/default/gpsd"
+ALTERNATIVE_TARGET[gpsd-defaults] = "${sysconfdir}/default/gpsd.default"