aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:49 +0100
committerArmin Kuster <akuster808@gmail.com>2016-05-02 14:03:03 -0700
commitcf1819332d48d3307aa2e80255834aa7911cd0dc (patch)
treef09b113c456f713beab1df0d084122eaca59570d /meta-oe/recipes-navigation
parent0e6cc19225103311e5c696618aec3fdaf8a10274 (diff)
downloadmeta-openembedded-cf1819332d48d3307aa2e80255834aa7911cd0dc.tar.gz
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index a300595687..aef9b138ab 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -30,12 +30,12 @@ inherit scons update-rc.d python-dir pythonnative systemd bluetooth
INITSCRIPT_NAME = "gpsd"
INITSCRIPT_PARAMS = "defaults 35"
-SYSTEMD_OESCONS = "${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false',d)}"
+SYSTEMD_OESCONS = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false',d)}"
export STAGING_INCDIR
export STAGING_LIBDIR
-PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
PACKAGECONFIG[bluez] = "bluez='true',bluez='false',${BLUEZ}"
PACKAGECONFIG[qt] = "qt='yes',qt='no',qt4-x11-free"
EXTRA_OESCONS = " \