aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2016-01-07 12:17:34 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-01-27 12:36:31 +0100
commit341253bd5729032844edb8cd1e6c4b512e1ae0cc (patch)
tree5501110f3059b27400c8c0df52c74626ef5c6971 /meta-oe/recipes-navigation
parentdc51449c479ec117715455640b4730f188611f41 (diff)
downloadmeta-openembedded-341253bd5729032844edb8cd1e6c4b512e1ae0cc.tar.gz
gpsd: Add patch to fix broken ACTIVATE hook.
This patch is already in mainline gpsd. It fixes a bug where the ACTIVATE hook for a device never gets called. Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-navigation')
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch35
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb1
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch
new file mode 100644
index 0000000000..7a06795057
--- /dev/null
+++ b/meta-oe/recipes-navigation/gpsd/gpsd-3.14/0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch
@@ -0,0 +1,35 @@
+From 6ff099b1ba8de74df9ddeb61e3825264b96ef692 Mon Sep 17 00:00:00 2001
+From: Moritz Fischer <moritz.fischer@ettus.com>
+Date: Tue, 22 Dec 2015 19:38:31 -0800
+Subject: [PATCH] libgpsd-core: Fix issue with ACTIVATE hook not being called.
+
+In the current system session->mode seemed to ignore the
+O_OPTIMIZE flag, leading to the ACTIVATE hook being ignored.
+
+Another way to fix this would be to keep the session->mode
+condition pull up the check for O_CONTINUE.
+
+Upstream-Status: Backported
+This patch is in upstream git
+
+Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com>
+---
+ libgpsd_core.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libgpsd_core.c b/libgpsd_core.c
+index 31fec2a..a84e85f 100644
+--- a/libgpsd_core.c
++++ b/libgpsd_core.c
+@@ -543,7 +543,7 @@ int gpsd_open(struct gps_device_t *session)
+ int gpsd_activate(struct gps_device_t *session, const int mode)
+ /* acquire a connection to the GPS device */
+ {
+- if (session->mode == O_OPTIMIZE)
++ if (mode == O_OPTIMIZE)
+ gpsd_run_device_hook(&session->context->errout,
+ session->gpsdata.dev.path, "ACTIVATE");
+ session->gpsdata.gps_fd = gpsd_open(session);
+--
+2.4.3
+
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
index f444ffce1f..ff268b35ea 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.14.bb
@@ -16,6 +16,7 @@ SRC_URI = "${SAVANNAH_GNU_MIRROR}/${BPN}/${BP}.tar.gz \
file://0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch \
file://0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch \
file://0001-Include-stdatomic.h-only-in-C-mode.patch \
+ file://0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch \
file://gpsd-default \
file://gpsd \
file://60-gpsd.rules \