aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/apcupsd
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-04-13 22:49:41 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-15 16:23:17 +0200
commita45830a39bb47a9eab27980d52966226c9504ea4 (patch)
tree001209d9740e8668b2eeeac4212b3561aecebf29 /meta-oe/recipes-support/apcupsd
parent6f48cf899aed0622f8fb26ffa144656a1143c9c5 (diff)
downloadmeta-openembedded-a45830a39bb47a9eab27980d52966226c9504ea4.tar.gz
recipes: Unify indentation
* This change is only aesthetic (unlike indentation in Python tasks). * Some recipes were using tabs. * Some were using 8 spaces. * Some were using mix or different number of spaces. * Make them consistently use 4 spaces everywhere. * Yocto styleguide advises to use tabs (but the only reason to keep tabs is the need to update a lot of recipes). Lately this advice was also merged into the styleguide on the OE wiki. * Using 4 spaces in both types of tasks is better because it's less error prone when someone is not sure if e.g. do_generate_toolchain_file() is Python or shell task and also allows to highlight every tab used in .bb, .inc, .bbappend, .bbclass as potentially bad (shouldn't be used for indenting of multiline variable assignments and cannot be used for Python tasks). * Don't indent closing quote on multiline variables we're quite inconsistent wheater it's first character on line under opening quote or under first non-whitespace character in previous line. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Acked-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/apcupsd')
-rw-r--r--meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb26
1 files changed, 13 insertions, 13 deletions
diff --git a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
index bd11f0da1c..5ab92fce7e 100644
--- a/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
+++ b/meta-oe/recipes-support/apcupsd/apcupsd_3.14.10.bb
@@ -15,25 +15,25 @@ EXTRA_OECONF = "--enable-usb \
--with-distname=${DISTRO}"
do_configure() {
- export topdir=${S}
- cp -a ${S}/autoconf/configure.in ${S}
+ export topdir=${S}
+ cp -a ${S}/autoconf/configure.in ${S}
- if ! [ -d ${S}/platforms/${DISTRO} ] ; then
- cp -a ${S}/platforms/unknown ${S}/platforms/${DISTRO}
- fi
+ if ! [ -d ${S}/platforms/${DISTRO} ] ; then
+ cp -a ${S}/platforms/unknown ${S}/platforms/${DISTRO}
+ fi
- gnu-configize --force
- # install --help says '-c' is an ignored option, but it turns out that the argument to -c isn't ignored, so drop the complete '-c path/to/strip' line
- sed -i -e 's:$(INSTALL_PROGRAM) $(STRIP):$(INSTALL_PROGRAM):g' ${S}/autoconf/targets.mak
- # Searching in host dirs triggers the QA checks
- sed -i -e 's:-I/usr/local/include::g' -e 's:-L/usr/local/lib64::g' -e 's:-L/usr/local/lib::g' ${S}/configure
+ gnu-configize --force
+ # install --help says '-c' is an ignored option, but it turns out that the argument to -c isn't ignored, so drop the complete '-c path/to/strip' line
+ sed -i -e 's:$(INSTALL_PROGRAM) $(STRIP):$(INSTALL_PROGRAM):g' ${S}/autoconf/targets.mak
+ # Searching in host dirs triggers the QA checks
+ sed -i -e 's:-I/usr/local/include::g' -e 's:-L/usr/local/lib64::g' -e 's:-L/usr/local/lib::g' ${S}/configure
- # m4 macros are missing, using autotools_do_configure leads to linking errors with gethostname_re
- oe_runconf
+ # m4 macros are missing, using autotools_do_configure leads to linking errors with gethostname_re
+ oe_runconf
}
do_install_append() {
- rm ${D}${datadir}/hal -rf
+ rm ${D}${datadir}/hal -rf
}