aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-03-20 13:33:50 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 15:38:32 +0200
commit4479cf9a6d4b476757ad6dc5ac7a9ece2432db5c (patch)
tree9002c3f7ee97ff3440d3ead7afbf8b06ecc878cd /meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb
parent6291199ee4c9dde2ac05e1d48372c667f92b14ff (diff)
downloadmeta-openembedded-4479cf9a6d4b476757ad6dc5ac7a9ece2432db5c.tar.gz
bash-completion: update to version 2.1
Notes: - PARALLEL_MAKE is still required - inherit allarch is not present because of runtime dependency with bash (TUNE_PKGARCH) Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb')
-rw-r--r--meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb b/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb
new file mode 100644
index 0000000000..bafe32d4fc
--- /dev/null
+++ b/meta-oe/recipes-support/bash-completion/bash-completion_2.1.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Programmable Completion for Bash 4"
+HOMEPAGE = "http://bash-completion.alioth.debian.org/"
+BUGTRACKER = "https://alioth.debian.org/projects/bash-completion/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SECTION = "console/utils"
+
+SRC_URI="http://bash-completion.alioth.debian.org/files/${BPN}-${PV}.tar.bz2"
+
+SRC_URI[md5sum] = "4e2a9f11a4042a38ee79ddcd048e8b9e"
+SRC_URI[sha256sum] = "2b606804a7d5f823380a882e0f7b6c8a37b0e768e72c3d4107c51fbe8a46ae4f"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+do_install_append() {
+ # compatdir
+ install -d ${D}${sysconfdir}/bash_completion.d/
+ echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
+
+ # Delete files already provided by util-linux
+ local i
+ for i in cal dmesg eject hexdump hwclock ionice look renice rtcwake; do
+ rm ${D}${datadir}/${BPN}/completions/$i
+ done
+}
+
+RDEPENDS_${PN} = "bash"
+
+# Some recipes are providing ${PN}-bash-completion packages
+PACKAGES =+ "${PN}-extra"
+FILES_${PN}-extra = "${datadir}/${BPN}/completions/ \
+ ${datadir}/${BPN}/helpers/"