aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/c-ares
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-03-18 00:19:48 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-17 19:46:35 -0700
commit81a32ac4808646d44929f33929b41e8b1524fff7 (patch)
tree616704340a55a0a3b8f04417401a99cebe36590b /meta-oe/recipes-support/c-ares
parenta0b1694970cd6e5b0b807f30417a2b9150d32a02 (diff)
downloadmeta-openembedded-81a32ac4808646d44929f33929b41e8b1524fff7.tar.gz
c-ares: upgrade 1.15.0 -> 1.16.0
add 0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch to fix error of do_configure refresh cmake-install-libcares.pc.patch Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/c-ares')
-rw-r--r--meta-oe/recipes-support/c-ares/c-ares/0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch27
-rw-r--r--meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch54
-rw-r--r--meta-oe/recipes-support/c-ares/c-ares_1.16.0.bb (renamed from meta-oe/recipes-support/c-ares/c-ares_1.15.0.bb)5
3 files changed, 43 insertions, 43 deletions
diff --git a/meta-oe/recipes-support/c-ares/c-ares/0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch b/meta-oe/recipes-support/c-ares/c-ares/0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch
new file mode 100644
index 0000000000..8f15f8424c
--- /dev/null
+++ b/meta-oe/recipes-support/c-ares/c-ares/0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch
@@ -0,0 +1,27 @@
+From f2f1e134bf5d9d0789942848e03006af8d926cf8 Mon Sep 17 00:00:00 2001
+From: Wang Mingyu <wangmy@cn.fujitsu.com>
+Date: Tue, 17 Mar 2020 12:53:35 +0800
+Subject: [PATCH] fix configure error : mv libcares.pc.cmakein to
+ libcares.pc.cmake
+
+Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3a5878d..c2e5740 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -563,7 +563,7 @@ IF (CARES_STATIC)
+ ENDIF()
+
+ # Write ares_config.h configuration file. This is used only for the build.
+-CONFIGURE_FILE (libcares.pc.cmakein ${PROJECT_BINARY_DIR}/libcares.pc @ONLY)
++CONFIGURE_FILE (libcares.pc.cmake ${PROJECT_BINARY_DIR}/libcares.pc @ONLY)
+
+
+
+--
+2.17.1
+
diff --git a/meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch b/meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch
index 8cadb2bbab..0eb7e4bbb3 100644
--- a/meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch
+++ b/meta-oe/recipes-support/c-ares/c-ares/cmake-install-libcares.pc.patch
@@ -12,39 +12,37 @@ update to 1.14.0, fix patch warning
Signed-off-by: Changqing Li <changqing.li@windriver.com>
---
- CMakeLists.txt | 23 +++++++++++++++++++++++
- libcares.pc.cmakein | 20 ++++++++++++++++++++
- 2 files changed, 43 insertions(+)
- create mode 100644 libcares.pc.cmakein
+ CMakeLists.txt | 28 +++++++++++++++++++++++-----
+ 1 file changed, 23 insertions(+), 5 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 60a880c..71eaa53 100644
+index fd123e1..3a5878d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -193,22 +193,30 @@ ADD_DEFINITIONS(${SYSFLAGS})
+@@ -214,22 +214,25 @@ ADD_DEFINITIONS(${SYSFLAGS})
# Tell C-Ares about libraries to depend on
+# Also pass these libraries to pkg-config file
+SET(CARES_PRIVATE_LIBS_LIST)
IF (HAVE_LIBRESOLV)
- LIST (APPEND CARES_DEPENDENT_LIBS resolv)
+- LIST (APPEND CARES_DEPENDENT_LIBS resolv)
+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lresolv")
ENDIF ()
IF (HAVE_LIBNSL)
- LIST (APPEND CARES_DEPENDENT_LIBS nsl)
+- LIST (APPEND CARES_DEPENDENT_LIBS nsl)
+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lnsl")
ENDIF ()
IF (HAVE_LIBSOCKET)
- LIST (APPEND CARES_DEPENDENT_LIBS socket)
+- LIST (APPEND CARES_DEPENDENT_LIBS socket)
+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lsocket")
ENDIF ()
IF (HAVE_LIBRT)
- LIST (APPEND CARES_DEPENDENT_LIBS rt)
+- LIST (APPEND CARES_DEPENDENT_LIBS rt)
+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lrt")
ENDIF ()
IF (WIN32)
- LIST (APPEND CARES_DEPENDENT_LIBS ws2_32)
+- LIST (APPEND CARES_DEPENDENT_LIBS ws2_32 Advapi32)
+ LIST (APPEND CARES_PRIVATE_LIBS_LIST "-lws2_32")
ENDIF ()
@@ -52,7 +50,7 @@ index 60a880c..71eaa53 100644
# When checking for symbols, we need to make sure we set the proper
# headers, libraries, and definitions for the detection to work properly
-@@ -514,6 +522,15 @@ CONFIGURE_FILE (ares_build.h.cmake ${PROJECT_BINARY_DIR}/ares_build.h)
+@@ -554,6 +557,15 @@ CONFIGURE_FILE (ares_build.h.cmake ${PROJECT_BINARY_DIR}/ares_build.h)
# Write ares_config.h configuration file. This is used only for the build.
CONFIGURE_FILE (ares_config.h.cmake ${PROJECT_BINARY_DIR}/ares_config.h)
@@ -68,8 +66,8 @@ index 60a880c..71eaa53 100644
# TRANSFORM_MAKEFILE_INC
#
-@@ -664,6 +681,12 @@ IF (CARES_INSTALL)
- INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/libcares.pc" DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
+@@ -728,6 +740,12 @@ IF (CARES_INSTALL)
+ INSTALL (FILES "${CMAKE_CURRENT_BINARY_DIR}/libcares.pc" COMPONENT Devel DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig")
ENDIF ()
+# pkg-config file
@@ -81,32 +79,6 @@ index 60a880c..71eaa53 100644
# Legacy chain-building variables (provided for compatibility with old code).
# Don't use these, external code should be updated to refer to the aliases directly (e.g., Cares::cares).
SET (CARES_FOUND 1 CACHE INTERNAL "CARES LIBRARY FOUND")
-diff --git a/libcares.pc.cmakein b/libcares.pc.cmakein
-new file mode 100644
-index 0000000..3579256
---- /dev/null
-+++ b/libcares.pc.cmakein
-@@ -0,0 +1,20 @@
-+#***************************************************************************
-+# Project ___ __ _ _ __ ___ ___
-+# / __|____ / _` | '__/ _ \/ __|
-+# | (_|_____| (_| | | | __/\__ \
-+# \___| \__,_|_| \___||___/
-+#
-+prefix=@CMAKE_INSTALL_PREFIX@
-+exec_prefix=@CMAKE_INSTALL_PREFIX@
-+libdir=@CMAKE_INSTALL_FULL_LIBDIR@
-+includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
-+
-+Name: c-ares
-+URL: http://daniel.haxx.se/projects/c-ares/
-+Description: asynchronous DNS lookup library
-+Version: @VERSION@
-+Requires:
-+Requires.private:
-+Cflags: -I${includedir} @CPPFLAG_CARES_STATICLIB@
-+Libs: -L${libdir} -lcares
-+Libs.private: @CARES_PRIVATE_LIBS@
--
-2.7.4
+2.17.1
diff --git a/meta-oe/recipes-support/c-ares/c-ares_1.15.0.bb b/meta-oe/recipes-support/c-ares/c-ares_1.16.0.bb
index d437529dc4..e235b9b954 100644
--- a/meta-oe/recipes-support/c-ares/c-ares_1.15.0.bb
+++ b/meta-oe/recipes-support/c-ares/c-ares_1.16.0.bb
@@ -5,13 +5,14 @@ SECTION = "libs"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=fb997454c8d62aa6a47f07a8cd48b006"
-PV = "1.15.0+gitr${SRCPV}"
+PV = "1.16.0+gitr${SRCPV}"
SRC_URI = "\
git://github.com/c-ares/c-ares.git \
file://cmake-install-libcares.pc.patch \
+ file://0001-fix-configure-error-mv-libcares.pc.cmakein-to-libcar.patch \
"
-SRCREV = "e982924acee7f7313b4baa4ee5ec000c5e373c30"
+SRCREV = "077a587dccbe2f0d8a1987fbd3525333705c2249"
UPSTREAM_CHECK_GITTAGREGEX = "cares-(?P<pver>\d+_(\d_?)+)"