aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ca-certificates
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-04-10 13:24:47 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2011-04-10 14:43:41 +0200
commit89500c583e0f1dc1b4ffdf72914e08e505e427e0 (patch)
treeb073036cc61aa34ca5ac9eec4d617366e0dcb3d5 /meta-oe/recipes-support/ca-certificates
parente66079da37992abd54486488aa06a99bf7a4198c (diff)
downloadmeta-openembedded-89500c583e0f1dc1b4ffdf72914e08e505e427e0.tar.gz
recipes,classes: import a lot of recipes from meta-shr
* tested on shr-lite-image for om-gta02 and nokia900 (with meta-shr layer)
Diffstat (limited to 'meta-oe/recipes-support/ca-certificates')
-rw-r--r--meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb40
-rw-r--r--meta-oe/recipes-support/ca-certificates/files/remove-c-rehash.patch29
2 files changed, 69 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb b/meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb
new file mode 100644
index 0000000000..7552c6f788
--- /dev/null
+++ b/meta-oe/recipes-support/ca-certificates/ca-certificates_20090814+nmu2.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Common CA certificates"
+HOMEPAGE = "http://packages.debian.org/sid/ca-certificates"
+SECTION = "misc"
+PRIORITY = "optional"
+LICENSE = "GPL"
+LIC_FILES_CHKSUM = "file://debian/copyright;md5=6275b491c91b57d92ebe11205ebf4dfe"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/c/ca-certificates/ca-certificates_${PV}.tar.gz \
+ file://remove-c-rehash.patch"
+SRC_URI[md5sum] = "76a2b0381b0aa7a6892e2340cd2c159a"
+SRC_URI[sha256sum] = "b1b144a3732df638e25b84ec6414ca9d1da4898cfd06d86b09f671585ce9c747"
+inherit autotools
+
+do_install_prepend() {
+ mkdir -p ${D}/usr/share/ca-certificates
+ mkdir -p ${D}/usr/sbin
+ mkdir -p ${D}/etc/ssl/certs
+ mkdir -p ${D}/etc/ca-certificates/update.d
+}
+
+do_install_append() {
+ cd ${D}/usr/share/ca-certificates
+ echo "# Lines starting with # will be ignored" > ${D}/etc/ca-certificates.conf
+ echo "# Lines starting with ! will remove certificate on next update" >> ${D}/etc/ca-certificates.conf
+ echo "#" >> ${D}/etc/ca-certificates.conf
+ for crt in $(find . -type f -name '*.crt' -print)
+ do
+ crt=$(echo $crt | sed -e 's/\.\///')
+ echo $crt >> ${D}/etc/ca-certificates.conf
+ done
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}"
+
+pkg_postinst_${PN} () {
+ /usr/sbin/update-ca-certificates
+}
+
+CONFFILES_${PN} = "/etc/ca-certificates.conf"
diff --git a/meta-oe/recipes-support/ca-certificates/files/remove-c-rehash.patch b/meta-oe/recipes-support/ca-certificates/files/remove-c-rehash.patch
new file mode 100644
index 0000000000..9d9b8ade3a
--- /dev/null
+++ b/meta-oe/recipes-support/ca-certificates/files/remove-c-rehash.patch
@@ -0,0 +1,29 @@
+--- ca-certificates-20090814/sbin/update-ca-certificates.orig 2010-02-25 19:25:08.272807308 +0100
++++ ca-certificates-20090814/sbin/update-ca-certificates 2010-02-25 19:25:33.962806273 +0100
+@@ -133,16 +133,16 @@
+ ADDED_CNT=$(wc -l < "$ADDED")
+ REMOVED_CNT=$(wc -l < "$REMOVED")
+
+-if [ "$ADDED_CNT" -gt 0 ] || [ "$REMOVED_CNT" -gt 0 ]
+-then
+- # only run if set of files has changed
+- if [ "$verbose" = 0 ]
+- then
+- c_rehash . > /dev/null
+- else
+- c_rehash .
+- fi
+-fi
++#if [ "$ADDED_CNT" -gt 0 ] || [ "$REMOVED_CNT" -gt 0 ]
++#then
++# # only run if set of files has changed
++# if [ "$verbose" = 0 ]
++# then
++# c_rehash . > /dev/null
++# else
++# c_rehash .
++# fi
++#fi
+
+ echo "$ADDED_CNT added, $REMOVED_CNT removed; done."
+