aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cpprest
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagna.gianfranco@gmail.com>2019-07-23 09:59:38 +0200
committerKhem Raj <raj.khem@gmail.com>2019-07-23 09:37:22 -0700
commitccf2220ab2e718c89d5fb576772c3120b90f69b9 (patch)
treefb0ef42839837d40a58fbb134d9af977ae6137be /meta-oe/recipes-support/cpprest
parent64a3c86711b3201ccd80508ab24c2578463bfa7b (diff)
downloadmeta-openembedded-ccf2220ab2e718c89d5fb576772c3120b90f69b9.tar.gz
cpprest: Do not export Werror from build system instead of adding -Wno-error to the same build command
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/cpprest')
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest_2.10.14.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.14.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.14.bb
index c13a632cf8..53f6469b28 100644
--- a/meta-oe/recipes-support/cpprest/cpprest_2.10.14.bb
+++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.14.bb
@@ -5,7 +5,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${S}/license.txt;md5=a2e15b954769218ff912468eecd6a02f"
DEPENDS = "openssl websocketpp zlib boost brotli"
-EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake -DCPPREST_EXCLUDE_BROTLI=OFF"
+EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake -DCPPREST_EXCLUDE_BROTLI=OFF -DWERROR=OFF"
SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \
file://disable-float-tests.patch \
@@ -17,5 +17,3 @@ SRCREV= "6f602bee67b088a299d7901534af3bce6334ab38"
S = "${WORKDIR}/git"
inherit cmake pkgconfig
-
-CXXFLAGS += "-Wno-error"