aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cramfs
diff options
context:
space:
mode:
authorImran Mehmood <Imran_Mehmood@mentor.com>2011-09-08 22:32:41 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-14 13:04:01 +0200
commite5340d912c01eb2f0b6cbe0fb174839818a8a665 (patch)
tree32475436b4afa86be46b614a6cb142064f874e01 /meta-oe/recipes-support/cramfs
parent15832ab1f64f2bc2ee7d342e5bff0351b5e2479b (diff)
downloadmeta-openembedded-e5340d912c01eb2f0b6cbe0fb174839818a8a665.tar.gz
cramfs: Adds cvs version recipe (initial recipe)
* Imported from oe.dev commit id e0728e428367d5534d6a56e452487529c5ec4918 * Added do_compile_prepend to make symbolic link named Makefile pointing to GNUmakefile to resolve missing Makefile error. Signed-off-by: Imran Mehmood <Imran_Mehmood@mentor.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support/cramfs')
-rw-r--r--meta-oe/recipes-support/cramfs/cramfs_cvs.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cramfs/cramfs_cvs.bb b/meta-oe/recipes-support/cramfs/cramfs_cvs.bb
new file mode 100644
index 0000000000..667097c861
--- /dev/null
+++ b/meta-oe/recipes-support/cramfs/cramfs_cvs.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Builds cramfs filesystems for embedded systems"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/linux/COPYING;md5=9579385572eb40eded61dcb07e0038a4"
+DEPENDS = "zlib"
+SRCDATE = "20110110"
+PV = "1.1+cvs${SRCDATE}"
+
+SRC_URI = "cvs://anonymous@cramfs.cvs.sourceforge.net/cvsroot/cramfs;module=linux"
+S = "${WORKDIR}/linux/scripts/cramfs"
+
+EXTRA_OEMAKE = "\
+ 'CC=${CC}' \
+ 'CFLAGS=${CFLAGS}' \
+ 'LDFLAGS=${LDFLAGS}' \
+"
+
+
+do_compile_prepend() {
+ ln -s GNUmakefile Makefile
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install mkcramfs ${D}${bindir}
+ install cramfsck ${D}${bindir}
+}
+
+BBCLASSEXTEND = "native"
+