aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbtest/fb-test_git.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-07-13 09:11:50 +0000
committerEric Bénard <eric@eukrea.com>2012-07-13 11:27:17 +0200
commit372f86378b29aeddfe5aa52a43a9fa7528eda614 (patch)
treec616b45f441553605990af53f63c6d9b5298d9ab /meta-oe/recipes-support/fbtest/fb-test_git.bb
parent32afac217b40e313c39baba73dc7023a26099e4b (diff)
downloadmeta-openembedded-372f86378b29aeddfe5aa52a43a9fa7528eda614.tar.gz
fb-test: add latest git version
This is a suite of utils to test the linux framebuffer and aid in debugging problems. Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Eric Bénard <eric@eukrea.com>
Diffstat (limited to 'meta-oe/recipes-support/fbtest/fb-test_git.bb')
-rw-r--r--meta-oe/recipes-support/fbtest/fb-test_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fbtest/fb-test_git.bb b/meta-oe/recipes-support/fbtest/fb-test_git.bb
new file mode 100644
index 0000000000..43acfd6b89
--- /dev/null
+++ b/meta-oe/recipes-support/fbtest/fb-test_git.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Test suite for Linux framebuffer"
+
+PV = "0.0"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
+
+SRCREV = "85eab266b123a08098af86afdb1599947d276e32"
+SRC_URI = "git://github.com/prpplague/fb-test-app.git"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${bindir}
+ for prog in perf rect fb-test offset ; do
+ install -m 0755 $prog ${D}${bindir}
+ done
+}
+