aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fltk
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-07-30 23:52:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2012-07-31 00:14:55 +0200
commit4339668ff27c839af1a1e4cfa5a2d034afe204f2 (patch)
treed2a48dca9a2a46a944e5091bf9b157cb2dc15e44 /meta-oe/recipes-support/fltk
parentf2afdd2b988af8d0b4d822c7c03529b725fe24ba (diff)
downloadmeta-openembedded-4339668ff27c839af1a1e4cfa5a2d034afe204f2.tar.gz
fbreader, fltk, gpm, iksemel, joe, links, ode, openldap, opensync, xchat: import from meta-smartphone
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fltk')
-rw-r--r--meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch13
-rw-r--r--meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch13
-rw-r--r--meta-oe/recipes-support/fltk/fltk_1.1.10.bb37
3 files changed, 63 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch
new file mode 100644
index 0000000000..8c01a1f806
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/disable_test.patch
@@ -0,0 +1,13 @@
+Index: fltk-1.1.9/Makefile
+===================================================================
+--- fltk-1.1.9.orig/Makefile 2008-06-06 16:14:11.936736201 +0200
++++ fltk-1.1.9/Makefile 2008-06-06 16:14:22.526357637 +0200
+@@ -27,7 +27,7 @@
+
+ include makeinclude
+
+-DIRS = $(IMAGEDIRS) src fluid test documentation
++DIRS = $(IMAGEDIRS) src fluid documentation
+
+ all: makeinclude fltk-config
+ for dir in $(DIRS); do\
diff --git a/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch b/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch
new file mode 100644
index 0000000000..867e9efcbf
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk-1.1.10/dso-fix.patch
@@ -0,0 +1,13 @@
+src/fl_set_fonts_xft.cxx is using fontconfig symbols
+
+--- a/makeinclude.in 2012-01-26 18:09:58.628799060 +0100
++++ b/makeinclude.in 2012-01-26 18:08:58.115801758 +0100
+@@ -81,7 +81,7 @@
+ AUDIOLIBS = @AUDIOLIBS@
+ DSOFLAGS = -L. @DSOFLAGS@
+ LDFLAGS = $(OPTIM) @LDFLAGS@
+-LDLIBS = @LIBS@
++LDLIBS = @LIBS@ -lfontconfig
+ GLDLIBS = @GLLIB@ @LIBS@
+ LINKFLTK = @LINKFLTK@
+ LINKFLTKGL = @LINKFLTKGL@
diff --git a/meta-oe/recipes-support/fltk/fltk_1.1.10.bb b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
new file mode 100644
index 0000000000..2611b20650
--- /dev/null
+++ b/meta-oe/recipes-support/fltk/fltk_1.1.10.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
+HOMEPAGE = "http://www.fltk.org"
+SECTION = "libs"
+LICENSE = "LGPLv2 & FLTK"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1c0b73db66884b6a925e727400315130"
+
+DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
+
+SRC_URI = "ftp://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/fltk/${PV}/fltk-${PV}-source.tar.bz2 \
+ file://disable_test.patch \
+ file://dso-fix.patch \
+ "
+
+S = "${WORKDIR}/fltk-${PV}"
+
+inherit lib_package autotools binconfig
+
+TARGET_CC_ARCH += "${LDFLAGS} -DXFT_MAJOR=2"
+
+EXTRA_OECONF = "--enable-shared \
+ --enable-threads \
+ --enable-xdbe --enable-xft --enable-gl \
+ --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}"
+
+do_configure() {
+ oe_runconf
+}
+
+python populate_packages_prepend () {
+ if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
+ bb.data.setVar('PKG_${PN}', 'libfltk${PV}', d)
+}
+
+LEAD_SONAME = "libfltk.so"
+
+SRC_URI[md5sum] = "a1765594bc427ff892e36089fe1fa672"
+SRC_URI[sha256sum] = "37ada22bf2586b8dd30d84209b8b58bdcb864627e5d02ae3f2c323a29261b19a"