aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
diff options
context:
space:
mode:
authorVyacheslav Yurkov <uvv.mail@gmail.com>2018-10-08 11:17:49 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-08 09:52:04 -0700
commit2d842ee7a3d0f38ca9735246b694c5093e8130d7 (patch)
tree4c4236de75668e38718ef278fdf23865f3c01f43 /meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
parent463fd3dff33457ba8fc519a2716f3270e054d533 (diff)
downloadmeta-openembedded-2d842ee7a3d0f38ca9735246b694c5093e8130d7.tar.gz
glog: upgrade 0.3.4 -> 0.3.5
Upgraded glog recipe to a new stable version in favor of cmake configuration Old configure.ac patch is removed. Another cmake patch is added. When UNWIND_LIBRARY is used directly as a public dependency then absolute path is stored in cmake config file. This is an issue when glog is used as part of generated SDK, which was built on another machine. When SDK is installed on developer's machine, cmake config contains a full path to non-existent location. The solution is to find libunwind during configure stage and store target name as a dependency, not a full path Signed-off-by: Vyacheslav Yurkov <uvv.mail@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch')
-rw-r--r--meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch b/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
new file mode 100644
index 0000000000..33dc9d38a2
--- /dev/null
+++ b/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
@@ -0,0 +1,30 @@
+diff -ur git/CMakeLists.txt ../0.3.5-r0.unwind/git/CMakeLists.txt
+--- git/CMakeLists.txt 2018-10-08 08:54:15.118989400 +0200
++++ ../0.3.5-r0.unwind/git/CMakeLists.txt 2018-10-05 16:26:59.745922318 +0200
+@@ -384,7 +384,9 @@
+ set_target_properties (glog PROPERTIES POSITION_INDEPENDENT_CODE ON)
+
+ if (UNWIND_LIBRARY)
+- target_link_libraries (glog PUBLIC ${UNWIND_LIBRARY})
++ add_library(unwind SHARED IMPORTED)
++ set_target_properties(unwind PROPERTIES IMPORTED_LOCATION ${UNWIND_LIBRARY})
++ target_link_libraries (glog PUBLIC unwind)
+ endif (UNWIND_LIBRARY)
+
+ if (HAVE_PTHREAD)
+diff -ur git/glog-config.cmake.in ../0.3.5-r0.unwind/git/glog-config.cmake.in
+--- git/glog-config.cmake.in 2018-10-08 08:54:15.122989699 +0200
++++ ../0.3.5-r0.unwind/git/glog-config.cmake.in 2018-10-08 08:14:48.550745810 +0200
+@@ -4,4 +4,12 @@
+
+ @gflags_DEPENDENCY@
+
++find_library (UNWIND_LIBRARY NAMES unwind DOC "unwind library")
++mark_as_advanced (UNWIND_LIBRARY)
++
++if (UNWIND_LIBRARY)
++ add_library(unwind SHARED IMPORTED)
++ set_target_properties(unwind PROPERTIES IMPORTED_LOCATION ${UNWIND_LIBRARY})
++endif (UNWIND_LIBRARY)
++
+ include ("${CMAKE_CURRENT_LIST_DIR}/glog-targets.cmake")