aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-08-22 23:01:23 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:04 +0200
commit00197a9bdb650097707ff98c99c7f16322db8fa8 (patch)
treededb87548aadf97c11d8726f9c7bfbbb33aefdab /meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb
parent9df486a293bdd28150815deb6416dd20917ee268 (diff)
downloadmeta-openembedded-00197a9bdb650097707ff98c99c7f16322db8fa8.tar.gz
gnulib: upgrade to 2017-08-20.18
Get version number by invoking: ... $ ${S}/build-aux/git-version-gen --version git-version-gen 2017-08-20.18 ... The gnulib 2017-08-20.18 fixed CVE-2017-7476. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb')
-rw-r--r--meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb b/meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb
new file mode 100644
index 0000000000..b505ac18dd
--- /dev/null
+++ b/meta-oe/recipes-support/gnulib/gnulib_2017-08-20.18.bb
@@ -0,0 +1,36 @@
+SUMMARY = "The GNU portability library"
+DESCRIPTION = "A collection of software subroutines which are designed to \
+be usable on many operating systems. The goal of the project \
+is to make it easy for free software authors to make their \
+software run on many operating systems. Since source is designed \
+to be copied from gnulib, it is not a library per-se, as much \
+as a collection of portable idioms to be used in other projects."
+
+HOMEPAGE = "http://www.gnu.org/software/gnulib/"
+SECTION = "devel"
+LICENSE = "LGPLv2+"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
+SRCREV = "b23000de1e47c7d580e0e220966dd1ee42a5e5bc"
+
+SRC_URI = "git://git.sv.gnu.org/gnulib;protocol=git \
+"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ cd ${S}
+ git checkout master
+ git clone ${S} ${D}/${datadir}/gnulib
+}
+
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+do_package[noexec] = "1"
+do_packagedata[noexec] = "1"
+do_package_write_ipk[noexec] = "1"
+do_package_write_deb[noexec] = "1"
+do_package_write_rpm[noexec] = "1"
+
+BBCLASSEXTEND = "native"