aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gperftools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-16 19:43:47 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-17 12:34:21 -0800
commitb192e792cd0c72c19bf8f18217accf419d66b41e (patch)
tree41631b0f73c6410fb3d667154245a79f1f610605 /meta-oe/recipes-support/gperftools
parent0e67e06127ca1a314e2ff69b7586e5b4651e49ee (diff)
downloadmeta-openembedded-b192e792cd0c72c19bf8f18217accf419d66b41e.tar.gz
gperftools: Convert static and libunwind support to packageconfig
Disable libunwind on musl/arm gperftools is not buildable for mips in general so extend to musl as well Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/gperftools')
-rw-r--r--meta-oe/recipes-support/gperftools/gperftools_2.7.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/gperftools/gperftools_2.7.bb b/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
index fdb82519bc..731c83516b 100644
--- a/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
+++ b/meta-oe/recipes-support/gperftools/gperftools_2.7.bb
@@ -2,7 +2,6 @@ SUMMARY = "Fast, multi-threaded malloc() and nifty performance analysis tools"
HOMEPAGE = "https://github.com/gperftools/gperftools"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=762732742c73dc6c7fbe8632f06c059a"
-DEPENDS += "libunwind"
SRCREV = "9608fa3bcf8020d35f59fbf70cd3cbe4b015b972"
SRC_URI = "git://github.com/gperftools/gperftools \
@@ -20,7 +19,7 @@ S = "${WORKDIR}/git"
# On mips, we have the following error.
# do_page_fault(): sending SIGSEGV to ls for invalid read access from 00000008
# Segmentation fault (core dumped)
-COMPATIBLE_HOST_mipsarch_libc-glibc = "null"
+COMPATIBLE_HOST_mipsarch = "null"
# Disable thumb1
# {standard input}: Assembler messages:
# {standard input}:434: Error: lo register required -- `ldr pc,[sp]'
@@ -28,9 +27,11 @@ COMPATIBLE_HOST_mipsarch_libc-glibc = "null"
ARM_INSTRUCTION_SET_armv5 = "arm"
ARM_INSTRUCTION_SET_toolchain-clang_arm = "arm"
-# Ensure static libs are always enabled, as they seem to be not produced by
-# default at least on ARM.
-EXTRA_OECONF_append += " --enable-static"
+PACKAGECONFIG ?= "libunwind static"
+PACKAGECONFIG_remove_arm_libc-musl = "libunwind"
+
+PACKAGECONFIG[libunwind] = "--enable-libunwind,--disable-libunwind,libunwind"
+PACKAGECONFIG[static] = "--enable-static,--disable-static,"
PACKAGE_BEFORE_PN += "libtcmalloc-minimal"
FILES_libtcmalloc-minimal = "${libdir}/libtcmalloc_minimal*${SOLIBS} ${libdir}/libtcmalloc_minimal_debug*${SOLIBS}"