aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/lcov/lcov_1.14.bb
diff options
context:
space:
mode:
authorHorvath, Chris <chris.horvath@essvote.com>2019-05-22 16:12:45 +0000
committerKhem Raj <raj.khem@gmail.com>2019-05-23 08:26:14 -0700
commit10c7107c88a3badbffd41ffc5aa2ec21900b68bb (patch)
tree82228453c96e434aa0fcf314f3c6f990053d9a00 /meta-oe/recipes-support/lcov/lcov_1.14.bb
parentbde3a38d61754cc82288961ce6d1dcda6f9115be (diff)
downloadmeta-openembedded-10c7107c88a3badbffd41ffc5aa2ec21900b68bb.tar.gz
lcov: Upgrade 1.11 -> 1.14
Upgrade from lcov_1.11.bb to lcov_1.14.bb for GCC 8 support. Signed-off-by: Chris Horvath <chris.horvath@essvote.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/lcov/lcov_1.14.bb')
-rwxr-xr-xmeta-oe/recipes-support/lcov/lcov_1.14.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lcov/lcov_1.14.bb b/meta-oe/recipes-support/lcov/lcov_1.14.bb
new file mode 100755
index 0000000000..fd02f4a76b
--- /dev/null
+++ b/meta-oe/recipes-support/lcov/lcov_1.14.bb
@@ -0,0 +1,52 @@
+SUMMARY = "A graphical front-end for gcov"
+HOMEPAGE = "http://ltp.sourceforge.net/coverage/lcov.php"
+DESCRIPTION = "LCOV is a graphical front-end for GCC's coverage testing \
+tool gcov. It collects gcov data for multiple source files and creates \
+HTML pages containing the source code annotated with coverage information. \
+It also adds overview pages for easy navigation within the file structure. \
+LCOV supports statement, function and branch coverage measurement."
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+RDEPENDS_${PN} += " \
+ gcov \
+ perl \
+ perl-module-filehandle \
+ perl-module-getopt-std \
+ perl-module-digest-sha \
+ perl-module-constant \
+ perl-module-cwd \
+ perl-module-errno \
+ perl-module-file-basename \
+ perl-module-file-find \
+ perl-module-file-path \
+ perl-module-file-spec \
+ perl-module-file-spec-functions \
+ perl-module-file-spec-unix \
+ perl-module-file-temp \
+ perl-module-getopt-long \
+ perl-module-list-util \
+ perl-module-mro \
+ perl-module-overload \
+ perl-module-overloading \
+ perl-module-overload-numbers \
+ perl-module-parent \
+ perl-module-pod-usage \
+ perl-module-posix \
+ perl-module-re \
+ perl-module-safe \
+ perl-module-scalar-util \
+ perl-module-term-cap \
+ perl-module-text-parsewords \
+ perl-module-tie-hash \
+"
+
+SRC_URI = "http://downloads.sourceforge.net/ltp/${BP}.tar.gz"
+
+SRC_URI[md5sum] = "0220d01753469f83921f8f41ae5054c1"
+SRC_URI[sha256sum] = "14995699187440e0ae4da57fe3a64adc0a3c5cf14feab971f8db38fb7d8f071a"
+
+do_install() {
+ oe_runmake install PREFIX=${D}${prefix} CFG_DIR=${D}${sysconfdir}
+}
+